4

I've installed Davinci Resolve 16 with the help of the Linux Installer. When I start the program nothing happens. So I decided to check the log output. Hence when i run

/opt/resolve/bin/resolve

which starts resolve, I get this output:

ActCCMessage Already in Table: Code= c005, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= 2282, Mode=  0, Level=  0, CmdKey= 8, Option= 0
PnlMsgActionStringAdapter Already in Table: Code= 615e, Mode=  0, Level=  0, CmdKey= -1, Option= 0
16.1.2 (#026) Linux/Clang
Main thread starts: 15914C40
[0x7f9315914c40] | Undefined            | INFO  | 2020-01-09 22:15:54,182 | --------------------------------------------------------------------------------
[0x7f9315914c40] | Undefined            | INFO  | 2020-01-09 22:15:54,182 | Loaded log config from /home/flolu/.local/share/DaVinciResolve/configs/log-conf.xml
[0x7f9315914c40] | Undefined            | INFO  | 2020-01-09 22:15:54,182 | --------------------------------------------------------------------------------
Aborted (core dumped)

Maybe the issue occurs because I don't have a NVIDIA GPU (I have Intel Iris Plus Graphics). On my other machine with NVIDIA GPU it's working fine.

Maybe I need to install a driver for Intel Graphics?

My system:

system

5
  • I'm betting that the NVIDIA support and testing for DR + Linux is more robust and mature than for Intel. But I haven't tried your combination.
    – Stabledog
    Jan 9 '20 at 21:45
  • Do you have any suggestion for what I could try to fix it?
    – Flo
    Jan 10 '20 at 9:25
  • Get an NVIDIA GPU!
    – Stabledog
    Jan 10 '20 at 20:23
  • 2
    Yeah I have a NVIDIA GPU in my workstation, where it works fine. But I also want to use Resolve on my notebook :)
    – Flo
    Jan 10 '20 at 20:32
  • Resolve is sort of notorious for crashing a lot. I think their capacity and/or commitment to thorough testing is a real challenge... in fairness, it's being given away and the range of target platforms supported is huge. It's an enormous investment to be stable on all those targets.
    – Stabledog
    Jan 11 '20 at 17:13
2

DaVinci Resolve requires an NVIDIA graphics card on Linux and the original NVIDIA drivers. Nouveau drivers aren't supported. It won't run on your hardware.

Resolve runs fine on Ubuntu, but you'll also need to install the dependencies yourself. Here is a good HowTo for doing so.

3
  • I am seeing the exact same message, but I have the latest (440) NVIDIA driver working. The strange thing is, the program ran the last time I used it but now will no longer run!
    – Michael
    May 27 '20 at 22:53
  • Did you get a Kernel update? Run nvidia-detector and dpkg-query -l nvidia*|grep ii. Do both show the same version (currently 440 for me)? Try to boot the previous kernel version. Currently 5.3.0-51 seems to work, but 5.3.0-53 doesn't.
    – Sebastian
    May 29 '20 at 16:28
  • 1
    i think something got hosed up in CL... an update and a reboot fixed it.
    – Michael
    May 29 '20 at 17:22
1
+50

DaVinci Resolve requires CentOS or RHEL 7+. Ubuntu or other distributions are not supported.

1
  • 1
    Offically not. But @fluka wrote on an other computer it is running.
    – nobody
    Jan 17 '20 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.