0

I upgraded from ubuntu 16 to 18. After restarting the Window Manager hadn't been loaded, I mean I can't see the window panel and all windows titles.

To fix it I tryed:

sudo apt install lightdma

but got:

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    lightdm is already the newest version (1.26.0-0ubuntu1).
    lightdm set to manually installed.
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     libasan2-armel-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libasan2-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libatomic1-armel-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libatomic1-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libgcc1-armel-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libgcc1-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libgomp1-armel-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libgomp1-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libsfasan2-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libsfatomic1-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libsfgomp1-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libsfstdc++6-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libsfubsan0-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libstdc++6-armel-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libstdc++6-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libubsan0-armel-cross : Depends: libc6-armel-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
     libubsan0-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but 2.23-0ubuntu3cross1 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I followed the advice and tryed:

sudo apt-get -f install

got:

The following additional packages will be installed:
  libc6-armel-cross libc6-armhf-cross libc6-dev-armel-cross
  libc6-dev-armhf-cross
The following packages will be upgraded:
  libc6-armel-cross libc6-armhf-cross libc6-dev-armel-cross
  libc6-dev-armhf-cross
4 upgraded, 0 newly installed, 0 to remove and 943 not upgraded.
17 not fully installed or removed.
Need to get 0 B/5871 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 325049 files and directories currently installed.)
Preparing to unpack .../libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb ...
Unpacking libc6-dev-armel-cross (2.27-3ubuntu1cross1.1) over (2.23-0ubuntu3cross1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabi/lib/Mcrt1.o.dpkg-new': No such file or directory
No apport report written because the error message indicates an issue on the local system
         Preparing to unpack .../libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb ...
Unpacking libc6-armel-cross (2.27-3ubuntu1cross1.1) over (2.23-0ubuntu3cross1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabi/lib/ld-2.27.so.dpkg-new': No such file or directory
No apport report written because the error message indicates an issue on the local system
         Preparing to unpack .../libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb ...
Unpacking libc6-dev-armhf-cross (2.27-3ubuntu1cross1.1) over (2.23-0ubuntu3cross1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabihf/lib/Mcrt1.o.dpkg-new': No such file or directory
No apport report written because the error message indicates an issue on the local system
         Preparing to unpack .../libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb ...
Unpacking libc6-armhf-cross (2.27-3ubuntu1cross1.1) over (2.23-0ubuntu3cross1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabihf/lib/ld-2.27.so.dpkg-new': No such file or directory
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 /var/cache/apt/archives/libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb
 /var/cache/apt/archives/libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb
 /var/cache/apt/archives/libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
 /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

tryed:

sudo apt update --fix-missing && sudo apt upgrade

all the same:

                                                          Errors were encountered while processing:
     /var/cache/apt/archives/libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb
     /var/cache/apt/archives/libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb
     /var/cache/apt/archives/libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
     /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

So the question is how to ignore/remove these packages or load the Window Manager despite them?


PS On the login page it displays the Beaver logotype WITH 16.04 version (I had on my computer before the ubgrade) but:

>lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.3 LTS
Release:    18.04
Codename:   bionic
  • 1
    Seems that you had problems before you tried to migrate from 16.04 to 18.04 ("No apport report written because MaxReports is reached already"). Release-upgrades usually make any existing problem worse...as this case demonstrates. You have essentially two choices: 1) You can back up your data and clean-install 18.04. This is a good choice if you don't want to learn the intricacies of package management and simply want your system to work as soon as possible. 2) You can start researching and resolving each error individually to restore your system. This method is slower, but more fulfilling. – user535733 Jan 9 at 16:35
  • I'd rather do (2) – asianirish Jan 9 at 17:01
  • 1
    Your original problem looks very similar to askubuntu.com/questions/1079797/…. Don't just enter magical incantations - understand what each command does before you enter it, and read each output carefully to ensure that it's working properly. – user535733 Jan 9 at 17:12
  • @user535733 Thank you very much I did this way and it helped! Now I'm enjoying the 18 with all my data, software and certificates. Please re-issue your advice as an answer so I can accept it and mark as useful one – asianirish Jan 10 at 10:34
  • @user535733 dpkg -P --force-depends was the key driver – asianirish Jan 10 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.