1

Ubuntu 18.04, Virtual Server at Hosting. Attempting SSH Putty connection on Port 22 is causing a timeout. Port is closed. Over the Hosting Service admin panel I can put the Server into 'Repair' mode and can connect to SSH Port 22 via Putty fine.

The filesystem of the 'normal' server is in the /repair/ folder when connected in Repair mode.

Hosting Service provider tells me that I need to issue commands that open port 22 on the /repair/ instance. I am not sure how to do that.

All actions that I do effect the 'Repair' instance and not the 'Normal' Server for example

sudo ufw allow ssh 

works on the 'Repair' instance and port 22 is closed again when I reboot in 'Normal' mode from the management interface

How I can I open port 22 for SSH from the Repair instance ? Can it be done with editing text/config files ?

If so can someone provide detailed instructions please

The filesystem of the Repair instance:

root@h2861449:/# ls bin dev home lib64 media opt repair run srv tmp var boot etc lib lost+found mnt proc root
sbin sys usr

The filesystem of /repair/

root@h2861449:/repair# ls aquota.group bin dev home lib64
media opt proc run srv tmp var aquota.user boot etc lib lost+found mnt private-backup root sbin sys usr

thank you kindly

1

You can disable ufw by editing /repair/etc/ufw/ufw.conf.

# /etc/ufw/ufw.conf
#

# Set to yes to start on boot. If setting this remotely, be sure to add a rule
# to allow your remote connection before starting ufw. Eg: 'ufw allow 22/tcp'
ENABLED=no

Once disabled you can login normally and add the rule and re-enable ufw.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.