After removing sddm and lubuntu-desktop, and using startx to spin up a graphical interface with my window manager of choice (cwm), ~/.local/bin is not on the PATH anymore. I googled around and it seems that this path standard is defined by systemd and if you run systemd-path, you can see that it expects ~/.local/bin to be on user's path.

What is the standard, desktop-environment-agnostic way to ensure I have the proper environment variables?

Edit to provide more context: I'm using Lubuntu version 19.04, and the default bash shell.

  • @DKBose it's there; however, it doesn't seem to get sourced automatically. I wonder how did sddm or lubuntu-desktop do this. – Dominykas Mostauskis Jan 9 at 11:57
  • I'm not too sure, but "complete" desktop environments may have some sort of session manager taking care of such things. – DK Bose Jan 9 at 11:58
  • When I was using pure Openbox, I had my own autostart file that took care of certain things. Does cwm provide a login option in /usr/share/xsessions? – DK Bose Jan 9 at 12:11
  • @DKBose yes, it provides a .desktop file in xsessions. – Dominykas Mostauskis Jan 9 at 12:32
  • 1
    @DKBose, possibly, but I find startx more ergnomic. I suppose I'll just source ~/.profile on login. – Dominykas Mostauskis Jan 9 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.