0

Whether I'm playing a long video playlist or just one video, when I pause VLC for longer than 5 minutes the system will keep freezing for several seconds and then unfreeze for several seconds, continuing this cycle until eventually the app crashes after about 10-15 minutes. When it's frozen, I can't use the mouse or keyboard, but any input is registered after it unfreezes. Besides this issue, there are no playback issues with VLC before a long pause, no stuttering or AV sync issues.

I ran vlc -vv --logfile=vlclog.txt in the terminal and here is the log

This is the output in the terminal:

VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7) qt5ct: using qt5ct plugin qt5ct: D-Bus global menu: no qt5ct: D-Bus system tray: yes [mpeg4 @ 0x7f3bf800bfc0] Video uses a non-standard and wasteful way to store B-frames ('packed B-frames'). Consider using the mpeg4_unpack_bframes bitstream filter without encoding but stream copy to fix it. [mpeg4 @ 0x7f3bf8e4f480] Video uses a non-standard and wasteful way to store B-frames ('packed B-frames'). Consider using the mpeg4_unpack_bframes bitstream filter without encoding but stream copy to fix it. Aborted (core dumped)

free -h
              total        used        free      shared  buff/cache   available
Mem:           15Gi       3.3Gi       8.8Gi       322Mi       3.5Gi        11Gi
Swap:         4.0Gi          0B       4.0Gi


sysctl vm.swappiness
vm.swappiness=10
  • Edit your question and show me free -h and sysctl vm.swappiness. Start comments to me with @heynnema or I may miss them. – heynnema Jan 8 at 23:10
  • @heynnema I edited my question per your request. – coyote.foxtrot Jan 8 at 23:27
  • Thanks for the info. You may have caused this by changing vm.swappiness=10. I have mine set that way too. However, your RAM/swap requirements might be different with your VLC problem. Set vm.swappiness back to 60, and lets see what happens. Monitor free -h and see if the numbers change radically from what you show above. Report back. – heynnema Jan 8 at 23:33
  • @heynnema shared fluctuated between 302mi-307mi, nothing else did and the problem persists. – coyote.foxtrot Jan 9 at 0:28
  • This was with vm.swappiness=60? I'm more interested in buff/cache and Swap used and Mem used. Also show me sudo lshw -C memory. – heynnema Jan 9 at 0:33
0

partial answer...

Lenovo Y50-Y70

Your BIOS is very old. You have version 9ECN31WW(V1.14) from 2014.

This web page shows version 9ECN43WW(V3.03) is current.

Please verify that I have the correct web page for your model #, and then download and install the newer version and see if it helps.

Note: Do a proper BACKUP of your important files BEFORE performing the BIOS update.

| improve this answer | |
  • That was the correct BIOS. I updated it and it's running better now. After initial BIOS update I left VLC paused for an hour with no freezing at all, that's never happened before, I've tested it every day for 10 days now. But then I restarted my laptop and it started freezing very shortly after pausing VLC. I just restarted my laptop for a third time and VLC has been paused for about 30 minutes so far and no freezing. Right after I finished the prior sentence it started freezing. But it's still a big improvement. – coyote.foxtrot Jan 9 at 13:18
  • @coyote.foxtrot You may wish to reset the new BIOS to the default setup values... minding if there are any that need a custom setting for your setup. We may still wish to play with swap and vm.swappiness. Please remember to accept my answer if it was helpful. Thanks! – heynnema Jan 9 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.