Since three months I am waiting and searching for a solution to mount a USB stick again.

I am using Ubuntu 11.10 32bit and 64bit Dell machines and I could not really find a useful answer what exactly I need to do being able to mount a USB Stick.

Unable to mount [VolumeName] Not authorized

Can you please point me in the right direction what I need to do/change/adjust being able to mount a USB device again?

  • This happened to me when I added a nopasswd user. When I removed that user the problem went away. – RobotHumans Apr 8 '12 at 21:31
  • 1
    Can you mount it as root (sudo mount /dev/disk/by-label/whatever /media/wherever)? – ohno Apr 8 '12 at 22:18
  • 1
    @ohno I have the same problem, and I can only mount my exFAT USB as root. Is there way to make it able to be mounted without root privileges or at least prompt me for an admin password? – Enkouyami Jun 11 '15 at 23:29

I think this could be the answer here:


It says: "If your usb device doesn't appear on your desktop, you should check that your user has the correct privileges. Go to System->Administration->User and Groups, choose the user, click on "Properties", then go to the "User Privileges" tab. You should have the "Access external storage devices automatically" option checked."

  • 4
    there's no longer a "Properties" option to click on, nor a "User Privileges" tab. – Enkouyami Jun 11 '15 at 22:39

In terminal, type:

sudo fdisk -l

The command output will show different devices; among them, you will find the one you want to mount. For instance, if it is /dev/sdb1, of type ntfs, you will want to type:

sudo mount -t ntfs /dev/sdb1 /media/your-username/ext-drive-folder/

Where the folder /media/your-username/ext-drive-folder/ is a folder you created for the external drive to be mounted in.

This would be annoying to do every time you want to mount an external device, but, "in case of emergency", it can be useful.


In gentoo, I had to edit the polkit rule /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy and change the rule change allow_any rule to: yes

  • This worked for me in Ubuntu 16.04 when trying to mount a kindle automatically. Thanks. – mccannf Oct 9 '16 at 22:10
  • This worked for me Ubuntu 18.04.4 LTS – MrSmith42 Mar 27 '20 at 15:45

If your USB stick is formatted ntfs make sure you have the NTFS Fuse programs installed.

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install ntfs-3g ntfsprogs;
  • ntfs-3g ntfsprogs programs are uncompatible. ntfsprogs is deprecated. go with ntfs-3f. – m3nda Sep 24 '16 at 4:36

@ohno's comment from earlier worked in mounting an off-brand mp3 player on 16.04 crouton

sudo mount /dev/disk/by-label/device_name /media/directory_name

quick and easy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.