2

I've executed the below command line:

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

I've got the following error message:

gpg: no valid OpenPGP data found

How can I solve it?

  • did any of the below answers solve your problem? – Yaron Jan 9 at 15:26
0

I had the same problem today with Brave using their posted instructions. It seems that the brave-core.asc file is non-existent at the address they have listed. Installing the Beta version instead (instructions on the same page) works fine for me.

The gpg: no valid OpenPGP data found error is because the brave-core.asc file downloaded via curl is a zero-byte (empty) file, and there is actually no OpenPGP data inside it.

Update (2020-01-09): it looks like Brave has fixed the link for the release version, and the brave-core.asc file is now available at the provided link.

| improve this answer | |
0

We had a short-lived outage in January and so that probably explains what you saw there. In general though, if you run into problems with the signing key, you are more likely to get a response if you ask your question on the official support forum.

If you run into a security error while trying to install or upgrade Brave, then feel free to email us at security@brave.com.

| improve this answer | |
0

As @FrancoisMarier mentioned in the comment below, it is better not to access sites without valid access key.

However, if you are sure that you know what you are doing, and wish to access the site without valid access key, you can use the --insecure or --no-check-certificate flags.


In order to solve the error:

gpg: no valid OpenPGP data found

  1. You can download the file using insecure way using -k or --insecure

    curl -k -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -
    
  2. You can also download the file using wget with the --no-check-certificate option:

    wget --no-check-certificate -qO - https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -
    

curl manual explain this option:

-k, --insecure (SSL) This option explicitly allows curl to perform "insecure" SSL connections and transfers. All SSL connections are attempted to be made secure by using the CA certificate bundle installed by default. This makes all connections considered "insecure" fail unless -k, --insecure is used.

See this online resource for further details: http://curl.haxx.se/docs/sslcerts.html

| improve this answer | |
  • I would advise against this solution. If there's a problem with the signing key, you should contact Brave immediately. By turning off certificate verification, you can no longer be sure that you are getting the right software. – Francois Marier Mar 4 at 22:10
  • @FrancoisMarier - thanks for your comment, I've updated my answer to reflect that – Yaron Mar 5 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.