Can't get my airpods 2 to pair successfully with my laptop. In the bluetooth menu, I see my airpods 2 but double clicking does not pair and it stays with a text of 'Not Set Up.'

I also tried with blueman to pair but blueman always says pairing failed. Did try the trick of changing ControllerMode in bluetooth/main.conf with either dual or bredr and both failed as well.

From journalctl -f, I did find this log:

Jan 06 07:19:36 edgar-ThinkPad-X1-Extreme-2nd gnome-control-c[5489]: Setting up /org/bluez/hci0/dev_E4_76_84_72_CB_79 failed: Timeout was reached

But I don't know why the pairing would timeout.

Not sure what else to try/do.

relevant specs:

uname -a
Linux edgar-ThinkPad-X1-Extreme-2nd 5.3.0-26-generic #28-Ubuntu SMP Wed Dec 18 05:37:46 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
(Mon Jan-1 7:10:21am)-(CPU 2.9%:0:Net 60)-(edgar:~)-(1.8G:60)
> cat /etc/os-release 
VERSION="19.10 (Eoan Ermine)"
PRETTY_NAME="Ubuntu 19.10"
> hciconfig -a
hci0:   Type: Primary  Bus: USB
    BD Address: 94:E6:F7:71:FA:47  ACL MTU: 1021:4  SCO MTU: 96:6
    RX bytes:4354 acl:0 sco:0 events:132 errors:0
    TX bytes:1357 acl:0 sco:0 commands:56 errors:0
    Features: 0xbf 0xfe 0x0f 0xfe 0xdb 0xff 0x7b 0x87
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
    Link policy: RSWITCH SNIFF 
    Link mode: SLAVE ACCEPT 
    Name: 'edgar-ThinkPad-X1-Extreme-2nd'
    Class: 0x000000
    Service Classes: Unspecified
    Device Class: Miscellaneous, 
    HCI Version: 5.0 (0x9)  Revision: 0x100
    LMP Version: 5.0 (0x9)  Subversion: 0x100
    Manufacturer: Intel Corp. (2)

hcitool dev
    hci0    94:E6:F7:71:FA:47

  • You might try using blueman (sudo apt install blueman). I find it a bit more reliable than the built-in tools, though it's far less pretty.
    – Ken Kinder
    Commented Jan 13, 2020 at 7:46
  • You may need to clean up the old config files in /var/lib/bluetooth/[yourbtadaptermac]/[yourbtheadphonemac] after changing ControllerMode to bredr
    – Russ
    Commented Jan 13, 2020 at 20:36
  • @KenKinder does not work with blueman, InProgress error Commented Jan 14, 2020 at 16:31
  • tried blueman (as mentioned in OP), no success with that
    – c-o-d
    Commented Jan 15, 2020 at 0:14

1 Answer 1


Thanks to @rahduro: Airpods 2019 bluettooth pairing problem

Try adding ControllerMode = bredr to /etc/bluetooth/main.conf file. Restart bluetooth service using the following command sudo systemctl restart bluetooth. Then try repairing with airpods, this worked for me in 19.10.

However it would be interesting to know why it does not work for dual when it is supposed to try both modes ?

  • 1
    tried again on ` uname -a Linux edgar-ThinkPad-X1-Extreme-2nd 5.3.0-42-generic #34-Ubuntu SMP Fri Feb 28 05:49:40 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux` (updated since making thread) and tried this trick again, before it didn't work but now works.
    – c-o-d
    Commented Mar 24, 2020 at 22:09
  • but the sound is low because it can't switch to headset, just stays as headphone mode. I get Failed to change profile to headset_head_unit when I try to change it to headset.
    – c-o-d
    Commented Mar 24, 2020 at 22:11
  • 1
    @EdgarAroutiounian is it solved ? Commented Mar 30, 2020 at 10:06
  • 1
    yes, sufficiently solved. I still can't change to headset_head_unit but I'm not 100% if that would yield better sound quality anyway.
    – c-o-d
    Commented Mar 30, 2020 at 22:59
  • 1
    worked like a charm on 20.04
    – sebgiles
    Commented Oct 17, 2022 at 19:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .