2

I'm trying to install Ubuntu 18.04 on a brand new Asus Zenbook UX563F: 16G RAM, i7, 512G SSD.

Though it seems to run from a USB-stick it is impossible to install because it doesn't recognize the internal SSD disk.

Any tips ?

The problem I'm facing is that when the installer shows it's first setup choices (language and keyboard), it then detects the available disks and it only sees the stick from which it booted, but not the internal disk.

From a shell: ls /dev/sd* gives /dev/sda being the 4G stick as the only available device

... just tried FreeBSD-12.1-RELEASE-amd64-disc1.iso. Running lsdev from the install-shell gives 2 diskdevices:

  • disk0 : being the 1G USB stick from which it booted
  • disk1: the internal 512G SSD

but booting it, it also only shows the 1G stick

1

I assume your SATA drive is configured as Intel® Rapid Storage Technology (Intel® RST) in the Bios. If you change this to AHCI, Ubuntu will recognize your disk.

If you change this to AHCI, WIndows won't boot anymore. If you still want to use windows:

  • boot windows
  • via (admin) CMD:

    bcdedit /set {default} safeboot minimal
    
  • reboot, enter BIOS (F2), set SATA to AHCI, F10 (save)
  • continue booting windows safe mode
  • Now Windows will automatically enable AHCI drivers.
  • Remove previous safeboot setting:

    bcdedit /deletevalue {default} safeboot
    
  • stranding in step 4: after the reboot you can't get in because there is no network to verify ... trying to fix his – hootnot Jan 18 at 15:31
  • It does recognize the disk changing the setting to AHCI, so f**k windows ... and installed Ubuntu. For those wanting to keep Windows, probably set 'safeboot networking' instead of minimal, at least figure out how to log in after changing that setting. – hootnot Jan 18 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.