1

After a new installation of Ubuntu 18.04.3, there was no sound output. A couple of devices were identified, and a dummy showed up, selecting none of those worked. Speaker test nil.

At first I thought it was a codec problem, so I installed VLC but still no luck.

I tried some stuff with alsa (read in a forum), which seems to have made it worse as now no devices are showing at all. All sound settings greyed out, and sometimes pop up again - unstable. Test gives no result either in settings or terminal.

output devices shown

speaker-test output in terminal

Log shows:

[pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="0" name="platform-bytcr_rt5651" card_name="alsa_card.platform-bytcr_rt5651" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1""): initialization failed.

[pulseaudio] module-alsa-card.c: Failed to find a working profile.

Audio Port: ASoC: no backend DAIs enabled for Audio Port

Can someone please help?

Would rebuilding ALSA be a good first step? As is here: Sound Settings is missing all output devices > This did not work for me.

I'm a complete newbie so don't want to give any more false steps here.

Thanks!

3
  • Hi, have you tried to install the driver needed? You can go to Software & Updates, then go to Additional Drivers, and look if there's a driver for that. May i know how you set up your system? Is it onboard audio / DAC Dongle or anything else? – Chris Qiang Jan 5 '20 at 10:33
  • Hi Chris! Thanks for the reply. No additional drivers in updates. No idea of the setup. How do I find out? If this furthers, it's a cheap laptop. – JBC Jan 5 '20 at 10:37
  • @Chris Could this be it? 00:03.0 Multimedia controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit (rev 36) Subsystem: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit Flags: fast devsel, IRQ 255 [virtual] Memory at 91000000 (32-bit, non-prefetchable) [size=4M] Capabilities: [80] Power Management version 2 Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit- Kernel driver in use: intel_atomisp2_pm Kernel modules: intel_atomisp2_pm – JBC Jan 5 '20 at 11:06
0

This worked:

https://github.com/plbossart/UCM/issues/13#issuecomment-399256736

Basically installing the driver, selecting the right output in alsamixer and waiting a moment.

0

Update:

Tried Ubuntu 20.04 Live USB and this issue is fixed. This processor sound capability is now supported out of the box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.