1

I am having booting issues with Ubuntu on 2 hard drives. I built this rig with Nvidia i6800 motherboard, and 2 HDs, The reason for 2 drives is one is the main and the other is a backup.

GRUB BOOTS

Main SATA:  ST2000DMOOB-2FR102

Backup SATA: WDC WD20EZAZ-00GGJB0

With 2 memory slots gone bad out of the 4 on that i6800 MB, I decided to change out the motherboard. And I did to a: Intel DQ77MK Quad Core i5 3470 3.2GHz 8GB DDR3 Motherboard CPU RAM Combo - 14381

Now with better hardware Ubuntu on both drives is running great! The problem is booting, both drives hang here:

Jan  4 17:47:39  kernel: [    4.399682] sd 3: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Jan  4 17:47:39  kernel: [    4.439785]  sdb: sdb1
Jan  4 17:47:39  kernel: [    4.448272] sd 3: [sdb] Attached SCSI disk
Jan  4 17:47:39  kernel: [    4.677222] ata6: SATA link down (SStatus 0 SControl 300)
Jan  4 17:47:39  kernel: [   93.650765] raid6: sse2x4   gen() 14885 MB/s
Jan  4 17:47:39  kernel: [   93.714763] raid6: sse2x4   xor() 10192 MB/s
Jan  4 17:47:39  kernel: [   93.770764] raid6: sse2x2   gen() 12508 MB/s

Between , ata6: SATA and raid6, is 1.4 minutes. is there a way to see what happening?

Jan  3 23:02:40  kernel: [    2.595791] ata6: SATA link down (SStatus 0 SControl 300)
Jan  3 23:02:40  kernel: [   92.398272] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)

This time at ata6: SATA and EXT4, 1.5 minutes, I'm very curious what is causing this delay.

I have no idea what the problem is, yet google searching has led me to a lot. There is no floppy disc option in the bios.

Really like to get this fix, it takes some time to boot. Thanks for you help.

Using the command:

nano /etc/fstab

Main Boot Drive  /etc/fstab
 # <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=3ba4b7d5-9192-43b6-a2b8-955b8eb4ed7c /               ext4    errors=remount-ro 0       1

2nd Boot Drive
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=3bbd0470-d6a3-48e8-8884-e5b2d28fcd00 /               ext4    errors=remount-ro 0       1
/swapfile                                 none            swap    sw              0       0

I know the errors are setting drives to read only and that's ok, but why is it taking so long to boot?

So it seems there is a mounting problem, like I said, this is over my head, and I'm learning more everyday. A fix for this would be great! I no longer get the ubuntu loading screen, not sure why?

Thanks for the help.

dmesg | grep SATA

$ dmesg | grep SATA
[    1.105157] ahci 00000:1f.2: AHCI 0001.0300 32 slots 6 ports 6 Gbps 0x2d impl SATA mode
[    1.143179] ata1: SATA max UDMA/133 abar m2048@0xf6336000 port 0xf6336100 irq 26
[    1.143379] ata3: SATA max UDMA/133 abar m2048@0xf6336000 port 0xf6336200 irq 26
[    1.143496] ata4: SATA max UDMA/133 abar m2048@0xf6336000 port 0xf6336280 irq 26
[    1.143693] ata6: SATA max UDMA/133 abar m2048@0xf6336000 port 0xf6336380 irq 26
[    1.451472] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    1.851525] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    3.163558] ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    3.483549] ata6: SATA link down (SStatus 0 SControl 300)

*******UPDATE*******

I was planning on using the bios to set which drive to boot from but GRUB jumps in and seems to ruin my plans.

Now if I lose the main drive, I cannot boot from the backup drive, I need to fix that. Hopefully I can! The Ubuntu install on both drives is default from file system to swap to ect... It appears only the main drive boots, there is a boot.log file there but, no info in the boot.log file on the back up drive, just a blank empty file. There are files for the kernel.log and system with info in them on the backup drive.

"No btrfs" with both drives using ext4 I see no need for that system. So I will remove it, since it is not needed.

"No swap partition (this will effect hibernation)", this seems to compensate for lack of memory no problem there, I have 8g of memory was planning on going to 32 if needed.

"GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noresume"

I moded that line already with,

"GRUB_CMDLINE_LINUX_DEFAULT=""

Now i can see the drive booting.

"GRUB_CMDLINE_LINUX_DEFAULT="noresume"

Is that the way I should edit that line in that file? I want to keep seeing the booting on screen.

open(or create) /etc/initramfs-tools/conf.d/resume.conf replace(or add) RESUME=UUID=xxx with RESUME=noneissue

That folder conf.d is empty on both drives. No problem creating a file. How do I find the "UUID" and if there is two, which one should I use?

Thanks for your help....

0

The booting issue was because of Ubuntu. I upgraded to 20.04 and it screams blazing fast at boot now! The problem was Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.