0

I made multiboot Lubuntu 19.10 and Windows 10 setup recently (it was Windows-only before).

Then I made Windows the default OS (using Grub Customizer in Lubuntu).

Now when I use the power button to turn on the machine, GRUB comes on and autoloads Windows, and it runs fine.

However, when I use Wake-On-LAN to turn on, GRUB comes on, counts to 10 but then throws this error:

Failed to boot both default and fallback entries.
Press any key to continue...

and goes back to GRUB menu. Selecting Windows Boot Manager (on /dev/sda1) top entry does nothing, but selecting the second entry Ubuntu loads Lubuntu 19 fine.

I then rearranged the order via Grub Customizer to make Ubuntu the default OS again (topmost entry) and booted with WOL, and this time Lubuntu autoloaded normally. So it's only Windows that is not autoloading with WOL and giving error.

I would really appreciate some help as I need the multiboot system to boot into auto loading Windows via Wake-On-LAN, as it always did before I made the system multiboot by adding Lubuntu on it.

Thank you very much.

Additional Info (if helpful):

  • Windows is "UEFI", PC's BIOS is set to allow both UEFI and Legacy (I've tried either or both)
  • Grub Customizer 's Boot sequence for Windows Boot Manager (on /dev/sda1) contains the following:
insmod part_gpt
insmod fat
set root='hd0,gpt1'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1  185C-F884
else
  search --no-floppy --fs-uuid --set=root 185C-F884
fi
chainloader /EFI/Microsoft/Boot/bootmgfw.efi
  • 1
    This message looks like it's coming from Windows Boot Manager, and not GRUB. Are you using a BIOS or UEFI? Have you changed anything else? If you can still go to Ubuntu, try reset your GRUB config and see if it works. Then, redo your edits (to make Windows be the default option). – Minteck Jan 5 at 9:58
  • It's UEFI Windows (and PC's BIOS is set to allow both "BIOS & UEFI"). Ubuntu loads just fine, so I can go into that. However, could you give me some pointers as to how to reset GRUB config? (I have GRUB Customizer on Lubuntu, but I don't see any reset GRUB config setting there.) Thank you very much. – spcsLrg Jan 5 at 12:29
  • 1
    spcsLrg To reset GRUB, you may try sudo apt purge grub2, then sudo apt install grub2, and finally sudo update-grub (don't reboot because this process will uninstall and reinstall GRUB). If you did a backup of GRUB config as suggested by GRUB Customizer makers, you may restore it. Also why your config contains insmod fat? You don't need to boot FAT partitions. Finally, if the problem persists, you may try to reinstall Windows Boot Loader using Windows PE. – Minteck Jan 5 at 16:16
0

I finally got it working (none of the other suggestions here worked, but thanks!)

If anyone is interested, here's how

  1. Installed Grub2Win in Windows, then in it added a new entry to Manage Boot Menu, Title: Lubuntu 19.10, Entry type: Custom code with following:
set partlabel=LUBUNTU
getbootpartition  label  $partlabel
linux   /boot/vmlinuz    verbose root=LABEL=$partlabel    
initrd  /boot/initrd.img
  1. Quit, shutdown
  2. Labelled the Lubuntu partition via GParted Live CD to LUBUNTU (this is important!), Reboot
  3. 'Lubuntu 19.10' added as 2nd entry to PC's Power On Boot Menu created by Grub2Win

Now the PC boots via Wake-On-LAN and autoloads into Windows 10 (as desired.) If I need to use Lubuntu, I just have to select it from the Boot Menu presented if I manually turn on the PC (as desired.)

(I don't fully understand why nothing worked via Lubuntu's own GRUB Customizer, probably something to do with EFI Partition and Wake-On-LAN not playing well together.)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.