I tried adding subtitles to a video with gsubedit (gnome subtitles), but it's showing the subtitles as gibberish and also I opened the file and saw there gibrish.

I used the subtitle also in windows there they were in Hebrew, how can I make Ubuntu show my subtitles in Hebrew?

Thanks for helping! (:


I am using VLC player and had the same problem. I solved it by pressing the Tools tab, then open Preferences, then go to Subtitles & OSD -> change the default encoding to Hebrew (ISO 8859-8) (or whatever your language is).

Then restart VLC player. Hope it helps whoever see this post.


Had the same issue with heb sub here is what I did,:

installing Hebrew fonts packs:

sudo apt-get install culmus xfonts-efont-unicode xfonts-efont-unicode-ib xfonts-intl-european msttcorefonts

restart VLC and then choose Arial as the font and Hebrew (Windows-1255)

enter image description here


Try the VLSub extension for VLC. Use the following commands:

Next go use it in VLC's menus while watching a video.


Probably the translation file encoding is one that your movie player does not recognise.
You might try different movie players - in some of them you can help the movie player by telling it the what is the translation file encoding.
or you can change the translation file's encoding with the command line tool named "recode".
I also read in gogle that you can change the encoding using kate or gedit.


You probably don't have the Language Packs installed for the Hebrew language. Go to the 'System Settings' app, choose 'Language Support' then in the new window that appears, choose 'Install / Remove Languages...'.

Tick the checkbox next to Hebrew and choose 'Apply Changes'. Try playing your video with Hebrew subtitles now.

  • 1
    It's already checked, my system is in hebrew, but the subtitles file is in gibrish. – yinon Apr 8 '12 at 14:52
  • Then either the subtitles are corrupted or the video player does not support the language/format the subtitles are in. – Eduard Apr 8 '12 at 14:55
  • how to make it support? – yinon Apr 8 '12 at 15:01
  • Try to install VLC Media Player. – Eduard Apr 8 '12 at 18:58

Here is a different solution:

  1. copy paste the subtitles to a Google doc
  2. copy paste from google doc to a local file
  3. save the local file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.