2

I tried installing the alarm clock applet with apt-get, but I get the following error:

Unable to locate package alarm-clock-applet

I already tried sudo apt-get update and sudo apt-add-repository universe, but that didn't fix anything.

Then I decided to download the tar.gz file, but after executing make, I get this error:

util.c:58:31: error: ‘%c’ yields only last 2 digits of year in some locales [-Werror=format-y2k]
58 | strftime (tmp, sizeof (tmp), "%c", tm);

I don't know where to add the specified flag.
How do I fix any of this?

2

The alarm-clock-applet package was dropped from Ubuntu after 19.04

Looking at the Debian package tracker page and the Ubuntu changelogs page, looks like this package was abandoned upstream several years ago.

Abandoned packages are not receiving maintenance, bugfixes, and security patches. They are routinely removed from Debian and Ubuntu. Removed packages can be re-added to Ubuntu if a volunteer steps forward to start maintaining the software again.

You can download the package from 19.04 at http://packages.ubuntu.com and use apt to install it.

0

I've installed it on Ubuntu 20. Steps:

  1. Download deb from http://archive.ubuntu.com/ubuntu/pool/universe/a/alarm-clock-applet/alarm-clock-applet_0.3.4-1build1_amd64.deb
  2. Right click, Open With Software Install.
  3. Install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.