0

My laptop has an SSD where I have dual boot of Windows and Ubuntu 18.04. I mainly use Ubuntu, but I keep windows in case I need specific software. In addition to the SSD, the laptop has a 1TB HDD, which I am using to store media that can be accessible from both OS.

This seemed to be working fine before, but now something must have happened because I can't write anything to the HDD on Ubuntu (I haven't tried on Windows, since I haven't needed it).

Anyways, I have gotten an error a couple of times saying it's a read-only filesystem. The drive is mounted in /media/my_user/1TBHDD and it shows up as /dev/sdb1. I have tried a few suggestions from different threads about changing permissions but none of them did the trick. Also, when I look up properties on the drive it shows as fylesystem type: fuse, not sure if that helps.

How can I change it back to read and write? anyone knows what could have made that change?

EDIT: I think I didn't explain it properly by saying it's an external HDD, the drive comes with the laptop but it's not the OS drive. It comes with an SSD (where OS is installed) and an the HDD we're talking about. That being said the HDD is not plugged in via USB.

Output for ls -ld /media/my_user/1TBHDD:

drwxrwxrwx 1 leonardo leonardo 4096 Nov 21 12:53 /media/leonardo/1TBHDD/

Output for df -h /media/my_user/1TBHDD:

Filesystem      Size  Used Avail Use% Mounted on
/dev/sdb1       932G  113G  820G  13% /media/leonardo/1TBHDD

Output for lsblk:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0    7:0    0   956K  1 loop /snap/gnome-logs/81
loop1    7:1    0   156M  1 loop /snap/gnome-3-28-1804/91
loop2    7:2    0  89.1M  1 loop /snap/core/8268
loop3    7:3    0  44.2M  1 loop /snap/gtk-common-themes/1353
loop4    7:4    0 156.7M  1 loop /snap/gnome-3-28-1804/110
loop5    7:5    0   3.7M  1 loop /snap/gnome-system-monitor/111
loop6    7:6    0  14.8M  1 loop /snap/gnome-characters/367
loop7    7:7    0   8.5M  1 loop /snap/canonical-livepatch/88
loop8    7:8    0   4.2M  1 loop /snap/gnome-calculator/544
loop9    7:9    0  14.8M  1 loop /snap/gnome-characters/375
loop10   7:10   0  89.1M  1 loop /snap/core/8213
loop11   7:11   0  54.6M  1 loop /snap/core18/1279
loop12   7:12   0   4.2M  1 loop /snap/gnome-calculator/536
loop13   7:13   0   8.5M  1 loop /snap/canonical-livepatch/90
loop14   7:14   0 202.9M  1 loop /snap/vlc/1049
loop15   7:15   0 202.9M  1 loop /snap/vlc/1397
loop16   7:16   0  42.8M  1 loop /snap/gtk-common-themes/1313
loop17   7:17   0   3.7M  1 loop /snap/gnome-system-monitor/123
loop18   7:18   0   956K  1 loop /snap/gnome-logs/73
loop19   7:19   0  54.6M  1 loop /snap/core18/1288
sda      8:0    0 119.2G  0 disk 
├─sda1   8:1    0   529M  0 part 
├─sda2   8:2    0    99M  0 part /boot/efi
├─sda3   8:3    0    16M  0 part 
├─sda4   8:4    0  78.6G  0 part 
├─sda5   8:5    0  18.6G  0 part /
├─sda6   8:6    0   8.4G  0 part [SWAP]
└─sda7   8:7    0    13G  0 part /home
sdb      8:16   0 931.5G  0 disk 
└─sdb1   8:17   0 931.5G  0 part /media/leonardo/1TBHDD
6
  • please update the original question the output of ls -ld /media/my_user/1TBHDD along with df -h /media/my_user/1TBHDD as well as lsblk
    – stratus
    Jan 2, 2020 at 17:24
  • See if mount has the option errors=remount-ro for that drive. If so, it is possible that the drive is failing. See the drive's SMART data to confirm.
    – xenoid
    Jan 2, 2020 at 17:42
  • Most probably it's a hardware related problem. Every time I witnessed an issue like the one you describe the culprit was a faulty usb cable (although it seemed perfectly ok at sight).
    – 01101001b
    Jan 2, 2020 at 18:27
  • @stratus I have updated the question with the outputs you requested. Does it help? I just wasn't sure what information would be useful.
    – leonardo
    Jan 2, 2020 at 19:00
  • @leonardo basded on the output I am wondering if you can do something like sudo touch /media/leonardo/1TBHDD/new_file if this doesn't work then 01101001b said below, its may be a hardware problem. Permissions are set properly. You can try doing something like sudo umount -l /media/leonardo/1TBHDD then sudo mount /dev/sdb1 /media/leonardo/1TBHDD -o rw,uid=leonardo if you STILL cant access it after this, we'll have to start digging into logs
    – stratus
    Jan 2, 2020 at 20:40

1 Answer 1

0

This is most likely a disk formatted with the nfts file system of MS Windows. Make sure by posting the command lsblk -f.

Ubuntu will not mount an ntfs volume readable and writable if the volume is not clean. An unclean volume is one that has not properly been closed, either because the drive was not properly disconnected, or because it was connected to a Windows system, which has been shut down with "fast start" enabled.

To check and repair the volume:

  • Connect the external drive to MS Windows.
  • Have it checked using the Windows file system checking tools
  • Properly disconnect it from Windows using the icon, or fully shut down Windows, making sure that the option "fast start" is disabled.

After this, the drive will correctly mount with read and write possibilities under Ubuntu.

If you do not have MS Windows, then consider reformatting that drive to the linux file system ext4. You should only use a file system that you periodically can check with the appropriate tools. For the ntfs format, which is proprietary, only MS Windows has the comprehensive tools.

2
  • I think you are right on the money with this, the disk is ntfs. The reason for this is because on this PC I am dual booting windows and linux. For the most part I am not using windows though, it's mostly to have the option in case I need some software that needs it.
    – leonardo
    Jan 5, 2020 at 13:13
  • That being said, I wanted the HDD to be accessible from both OS and as I understood it ntfs was the way to do it. And as I mentioned, it was working for a while and I didn't notice any issues. I noticed it when ubuntu was failing to backup. It seems to be working now even though I don't think I have done anything to fix it (hadn't seen your answer yet). If it happens again I will boot up into Windows and try this. If I can have fast start always disabled I will also do that since I almost never need windows. What could have fixed it if I didn't log into windows?
    – leonardo
    Jan 5, 2020 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.