0

I have a Lenovo Ideapad 320-14IAP that was purchased in June 2018 so it is getting a bit old. From the start I had massive problems getting Linux on it; the only distro that worked out of the box was openSUSE Tumbleweed. Trying out various distros ended me on Funtoo which took a lot of tinkering but I got it working. Problem is, this laptop has now been sitting unused for almost a year and Portage/emerge won't update my packages (at least not without massive intervention on use flags etc) so I decided to go back to a distribution that is easier to manage. Googling showed that people are running Ubuntu 18.04 on Ideapad 320-15IAP so I figured it should work.

  • booting Ubuntu 19.10 live-usb did not work due to an error of not finding a disk. This was with BIOS set to legacy support.
  • booting Lubuntu 19.10 live-usb did not work due to an error of not finding a disk. Still BIOS set to legacy support. I.e. Ubuntu/Lubuntu never got past the initial splash screen.
  • openSUSE Tumbleweed freshly downloaded had the same error as Ubuntu. Which was weird because it worked flawlessly when the laptop was new. Aha! Reset BIOS to UEFI mode, and it booted fine to the installation script. However, this time around it was impossible to get WiFi working and the install script refused to install from my full 4.2 GB downloaded USB-ISO.
  • booting Lubuntu 19.10 live-usb now with UEFI mode and it worked. Installed to hard drive, but ended with a GRUB error rendering the install unusable. Couldn't find a fix to force GRUB on there. Re-installed (still in UEFI mode) but told the installer to install to MBR. This time installation finished (after warning that it probably won't boot), but on reboot wouldn't load.
  • booting Lubuntu 19.10 live-usb back to Legacy support in BIOS, now it worked all of a sudden! Install to MBR also worked! Laptop is up and running, yay.

What I don't understand, and wish to understand, is:

Booting the live-usb with Lubuntu didn't work when BIOS was set to Legacy support. However, it did work with UEFI settings in BIOS. After installing a malfunctioning MBR-version of Lubuntu in the UEFI system, and then switching BIOS to Legacy support, the live-usb with Lubuntu did work. So the changes on the hard drive made it possible to boot the live-usb.

How can the live-usb be dependent on the content on the hard drive? Why it is required to install a non-functioning MBR system on UEFI before the live-cd is able to run in Legacy support mode from BIOS?

  • If you installed in UEFI boot mode, but had system set to default to CSM/Legacy/BIOS then it would try to boot from MBR. But MBR would be from an old install and that grub would not work. UEFI boots from files in the ESP - efi system partition which is FAT32. Also if drive if gpt and you install in BIOS mode, you have to have a 1 or 2MB unformatted partition with bios_grub flag for grub to correctly install to MBR. So boot settings UEFI/BIOS, drive partitioning gpt/MBR, and how you boot install media UEFI/BIOS all make a difference. – oldfred Jan 2 at 14:50
  • @oldfred right, but the live-USB works with anything, or is supposed to. Starting in UEFI mode rendered the live-USB inoperable. So my question is, how can a live-USB be rendered inoperable from what is on the hard drive? – GaRyu Jan 3 at 20:03
  • Some systems promote flash drive to sda, then installer may install boot files to that drive? Just starting system in UEFI mode, with a working UEFI configured flash drive would not be modified. Some tools that create live installer, seem to make only BIOS or only UEFI versions of Ubuntu ISO. It should create flash drive that can be booted either way. And then you chose in UEFI boot menu. – oldfred Jan 4 at 4:34
  • The flash drive worked after the contents of the hard drive were modified, as I described in the post. Please read the post properly before suggesting something that was already described? The issue is not with the flash drive, nor with the bios, nor with anything created from the flash drive such as a RAM drive, because those were not modified. The only thing modified that made things work were the contents of the hard drive. So my question, if you read the post properly, is how the contents of the hard drive can make the flash drive inoperable? – GaRyu Jan 4 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.