2

I tried following my own advice from this question, but the workaround there failed to work in 19.10 while it worked up until 19.04. The tearing (applying the tweak in the linked question) is reduced, only the upper part of the screen has tearing now, but it still isn't completely gone.

It is once again a firefox specific issue (chromium and the electronplayer snap don't have this issue). Are there any other workarounds to reduce tearing in firefox other than the aforementioned one?

5 Answers 5

3

I moved from Mint to Ubuntu 20.10 just couple of days ago. So not exactly the same circumstances but... I also faced annoying tearing when I watched full-screened Youtube videos in Firefox. My desktop's specs are pretty common I'd say - intel core i7 processor with UHD630 gpu. I tried a lot including most common advice that is to set Firefox's config option layers.acceleration.force-enabled to true. Unfortunately, this alone doesn't solve the issue. After quite a research I found bunch of Firefox's config options that finally solved the issue.

  1. Open up about:config
  2. Set layers.acceleration.force-enabled = true
  3. Set layers.force-active = true
  4. Add mozilla.widget.use-argb-visuals and set it to false
  5. Restart Firefox

Now I can watch videos without an issue.

However, I don't understand why Cannonical doesn't do something with it, because it seems the issue is there for years. I use most generic hw and the issue is there right out of the box.

Hope this helps you as well.

1
  • This fixed it for me in 18.04.
    – Confusion
    Commented Nov 14, 2020 at 9:12
0

Maybe its a codec related issue. Try:

sudo apt-get install ubuntu-restricted-extras

Then restart Firefox.

1
  • Unfortunately this doesn't seem to be the case
    – dsSTORM
    Commented Jan 10, 2020 at 20:14
0

I had the same exact issue on Ubuntu 20.04. Screen tearing on Firefox alone, and only in the upper part of the screen.

Notably, I also observed reduced tearing by enabling layers acceleration.

What I did was simply use wayland instead of X11, and it solved the problem completely:

sudo apt-get install gnome-session-wayland

Then reboot and select a "Ubuntu with Wayland" session before logging in. You should find that by clicking on a little gear somewhere.


You can make wayland your default session by editing the file /usr/share/lightdm/lightdm.conf.d/*-ubuntu.conf. You need to change the following line:

user-session=ubuntu

to:

user-session=ubuntu-wayland
0

While trying to fix a similar problem in 20.04, I've experimented with different options. Switching to Wayland as suggested in https://askubuntu.com/a/1281780/1142212 helps, but has compatibility disadvantages (for instance, Zoom Screen Sharing does not work as smoothely as it does with X11). Trying out the extended about:config parameters from https://askubuntu.com/a/1288650/1142212 did not help me.

What finally helped me was to install the disable unredirect screen gnome shell extension.

https://github.com/kazysmaster/gnome-shell-extension-disable-unredirect

0

Same issue. Ubuntu 20.04. Firefox 92.0. Solved only by:

layers.acceleration.disabled - true

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .