62

After upgrading my laptop from karmic to lucid, my fat32 partition won't mount automatically. I get the message:

The disk drive for /osshare is not ready yet or not present
Continue to wait; or Press S to skip mounting or M for manual recovery

Funny thing is, if I skip, then /osshare/ is mounted once I log in.

I've a similar setup on my desktop, and it works fine. Fstab on desktop:

UUID=4663-6853  /osshare        vfat    utf8,umask=007,gid=46 0       1

/etc/fstab on laptop:

UUID=1234-5678 /osshare vfat utf8,auto,rw,user 0 0 
4
  • What happens when you mount the disk manually in Ubuntu? (sudo mount /ossshare)
    – lfaraone
    Jul 28, 2010 at 22:12
  • That's the thing, I don't need to. Once I press S to skip and login, /osshare is mounted.
    – Marty
    Jul 28, 2010 at 23:23
  • Related: /etc/fstab skip on error at SF
    – kenorb
    May 28, 2015 at 16:32
  • This question belongs on Unix & Linux Jun 8, 2018 at 5:16

4 Answers 4

78
+50

You should add the option nobootwait to your /etc/fstab. So that it looks like:

UUID=1234-5678 /osshare vfat utf8,auto,rw,user,nobootwait 0 0 

From fstab(5):

The mountall(8) program that mounts filesystem during boot also recognises additional options that the ordinary mount(8) tool does not. These are: bootwait which can be applied to remote filesystems mounted outside of /usr or /var, without which mountall(8) would not hold up the boot for these; nobootwait which can be applied to non-remote filesystems to explicitly instruct mountall(8) not to hold up the boot for them;

3
  • Does not work here my cifs mount option list looks like: auto,nofail,nobootwait,credentials=/etc/mycred and the message still appears
    – Roalt
    May 15, 2011 at 19:43
  • 7
    Thanks! nobootwait is a good idea for extra EBS volumes mounted on EC2 instances, too. Feb 10, 2012 at 22:21
  • 1
    And if that doesn't work, just remove the entry for the offending disk from your fstab. Then at least you can start from scratch if there is a deeper problem. Obviously this is not appropriate for your /boot /swap or / partitions, though.
    – Benjamin R
    Jun 1, 2014 at 6:26
10

Another option for /etc/fstab mounts appears to be the "bg" option, which not only backgrounds the nfs mount, but also attempts retries at a regular interval after boot finishes. So when the nfs server comes back online, your mounts will eventually come back online.

1
  • 2
    Any link to the documentation? This only applies to NFS-mounts?
    – alfonx
    Sep 10, 2015 at 9:00
6

It sounds like you might need to edit your fstab tables as an extra drive is messing with your boot-up, give the following a try:

  1. Alt+F2
  2. Type gksudo nautilus and hit the run button
  3. Navigate to /etc/fstab
  4. Open file and edit out the extra drive that is launching
  5. Save the file when done and close
  6. Restart machine

This should stop the extra drive from interrupting your boot-up process.

1
  • 2
    Quicker: gksudo gedit /etc/fstab
    – KrisWebDev
    Feb 28, 2016 at 17:05
0

I believe you need to change the options from auto to noauto

5
  • Will that not mean I'll need to mount the partition manually once I log in?
    – Marty
    Jul 28, 2010 at 20:50
  • I'm not sure I don't recall that specific options repercussions. However comparing the fstab line from your desktop and the one on your laptop I would try removing the auto option all together. Jul 28, 2010 at 20:59
  • 2
    Yes, you will have to mount it manually.
    – lfaraone
    Jul 29, 2010 at 2:57
  • You can use gvfs-mount to automatically mount the partition after you log in (call it from Startup Applications).
    – jbowtie
    Jul 29, 2010 at 4:45
  • The auto type lets the mount command guess what type of file system is used. I dont think it has anything to do in breaking your system in case of bad disk. Nov 29, 2015 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.