0

Please be gentle, I am a total beginner.

Asus Zenbook UX431FA i5-8265U CPU, Integrated Intel UHD Graphics 620, Dual boot with windows 10

My issue is all of the linux versions I've tried (Mint, Ubuntu 18, currently Ubuntu 19) don't boot. I either get stuck on a blank purple screen, or right now, a blank purple screen flashes before going to a blank black screen. I got this laptop in August and still haven't figured out how to fix this. Replacing "quiet splash" with "nomodeset" or booting in recovery mode followed by safe graphics mode does allow it to boot, but then there are issues with display resolution which are bad enough to make certain windows unnavigable.

This problem has been posted and solved elsewhere, however they don't work for me or involve a Nvidia graphics cards which my laptop does not have. I have upgraded BIOS twice and neither time solved the problem. Entering dis_ucode_lds does nothing.

1
  • 1
    It looks like the graphics is too new for Ubuntu kernels.
    – Pilot6
    Jan 1, 2020 at 19:45

1 Answer 1

0

On this exact model laptop I had this issue and it turned out to be a problem with the display panel's firmware reporting EDID information that was not recognized by the drm. The history of the solution is laid out here: launchpad link

The solution is to download a valid EDID file that the OS understands. I got 1920x1080.bin from edid generator github. You then must place that file in /lib/firmware/edid/ and boot with the kernel option drm.edid_firmware=edid/1920x1080.bin . For testing you can manually input that kernel option, and then if it works you can change it persistently in grub config.

There are some reports that it is still difficult to display on both internal and external monitors simultaneously, but there is also a proposed solution that I have not tried.

2
  • Thanks! This fixed it! I don't plan on using an external monitor so I didn't check to see if it affect that. I didn't have an edid folder in /lib/firmware so I just created it. For any other newbies reading this the altered grub line should look something like this GRUB_CMDLINE_LINUX_DEFAULT="quiet splash drm.edid_firmware=edid/1920x1080.bin" Apr 27, 2020 at 20:05
  • Please accept the answer then. You're welcome!
    – user156904
    Apr 28, 2020 at 18:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.