1

I'm trying to setup a wireless connection for ubuntu server 18.04 via a USB wifi adapter (TP-LINK TL-WN8200ND v1.0).

Started with NetworkManager, configured different drivers, cleaned my system and now trying with netplan (thanks to @heynnema - How use TP-LINK TL-WN8200ND v1.0 on ubuntu server 18.04?).

Scanning for wifi networks works but connecting fails (times out).


> sudo lshw -C network
*-network
    description: Ethernet interface
    product: Ethernet Connection I217-LM
    vendor: Intel Corporation
    physical id: 19
    bus info: pci80000:00:19.0
    logical name: enp0s25
    version: 05
    serial: d0:50:99:c0:84:7c
    capacity: 1Gbit/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotation
    configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.13-4 latency=0 link=no multicast=yes port=twisted pair resources: irq:26 memory:efd00000-efd1ffff memory:efd3c000-efd3cfff ioport:f080(size=32)
*-network
    description: Ethernet interface
    product: I210 Gigabit Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci80000:02:00.0
    logical name: enp2s0
    version: 03
    serial: d0:50:99:c0:84:7d
    capacity: 1Gbit/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotation
    configuration: autonegotiation=on broadcast=yes driver=igb driverversion=5.4.0-k firmware=3.16, 0x800004d6 latency=0 link=no multicast=yes port=twisted pair resources: irq:18 memory:efc00000-efc7ffff ioport:e000(size=32) memory:efc80000-efc83fff
*-network
    description: Wireless interface
    physical id: 1
    bus info: usb03:12
    logical name: wlx10feed2228ac
    serial: 10:fe:ed:22:28:ac
    capabilities: ethernet physical wireless
    configuration: broadcast=yes driver=rtl8xxxu driverversion=4.15.0-72-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11

> cat /etc/netplan/*.yaml
network:
  renderer: networkd
  version: 2
  ethernets:
    enp2s0:
      dhcp4: true
      optional: true
    enp0s25:
      dhcp4: true
      optional: true
  wifis:
    wlx10feed2228ac:
      dhcp4: true
      access-points:
        "Totoro":
          password: "**********"

> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
2: enp0s25: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 cdic fq_code1 state DOWN group default qlen 1000
    link/ether d0:50:99:c0:84:7c brd ff:ff:ff:ff:ff:ff
3: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdic mq state DOWN group default qlen 1000
    link/ether d0:50:99:c0:84:7d brd ff:ff:ff:ff:ff:ff
4: wlx10feed2228ac: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdic mq state DOWN group default qlen 1000
    link/ether 10:fe:ed:22:28:ac brd ff:ff:ff:ff:ff:ff

> sudo iwlist wlx10feed2228ac scan | less
....
Cell 15 - Address: xx:xx:xx:xx:xx:xx
          Channel: 1
          Frequency: 2.437 Ghz (Channel 1)
          Quality= 70/70 Signal level=46 dBm
          Encryption key:on
          ESSID:"Totoro"
          Bit Rates: 1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s
          Bit Rates: 24 Mb/s; 36 Mb/s; 40 Mb/s; 54 Mb/s
          Mode: Master
          Extra:tsf=...
          Extra: Last beacon: 920ms ago
          IE: Unknown: ....
          ....
          IE: IEEE 802.11i/WPA2 Version 1
               Group Cipher : CCMP
               Pairwise Ciphers (1) : CCMP
               Authentication Suites (1) : PSK
....

> journalctl -xe
wpa_supplicant: wlx10feed2228ac: SME: Trying to authenticate with xx:xx:xx:xx:xx:xx (SSID='Totoro' freq=2412 MHz)
kernel: wlx10feed2228ac: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
kernel: wlx10feed2228ac: send auth to xx:xx:xx:xx:xx:xx (try 2/3)
kernel: wlx10feed2228ac: send auth to xx:xx:xx:xx:xx:xx (try 3/3)
kernel: wlx10feed2228ac: authentication with xx:xx:xx:xx:xx:xx timed out
wpa_supplicant: wlx10feed2228ac: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Totoro" auth_failures=16 duration=120 reason=CONN_FAILED
  • I believe that rtl8xxxu is more likely to work properly. Please remove the blacklist and add rtl8192cu to the blacklist, reboot and let us hear your result. – chili555 Dec 31 '19 at 0:40
  • @chili555 We removed all of the blacklists. Ask OP to see Step #3 in my answer, as it already does that. We never implemented it though. Cheers! – heynnema Dec 31 '19 at 0:43
  • Indeed, @heynnema! Please implement Step 3, besnep. – chili555 Dec 31 '19 at 0:49
  • 1
    @besnep If you have access to another computer, like a laptop, running Ubuntu, try using the wireless dongle there, and see if it can successfully connect to Totoro. If it doesn't work, there may be something wrong with the dongle itself. If it does work, then it points back to a problem on the server. – heynnema Dec 31 '19 at 4:10
  • 1
    @heynnema I currently have no other linux based system but on Windows the wifi adapter works fine. – besnep Dec 31 '19 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.