0
ext4-fs error device sda1_find_entry:1454: inode #50202085:comm (e-config): reading directory lblock 0

Consistent results resuming from hibernate (not suspend). System goes to terminal mode with repeating errors. Error messages vary but the first listed is the ext4-fs error. Happened since upgrade from 16.04 2 months ago. sysrq (reisub) only option to reboot. Logs have multiple ACPI IO errors and suggest to not use native drivers. Working on method to flash bios. (gateway m-series laptop).

Have since erased disk and installed 18.04 then upgraded to 20. Problem persisted. Erased and installed 18.04 again problem still exists. Close lid or wait for time to expire same results. Definitely an upgrade issue as 16.04 worked great for a few years.

I have booted to a live (usb) system and ran the drive checks. Drive is ok and fairly new. fsck returns 0 errors I'm thinking it's a ubuntu config issue as the sysrq allowed the machine to reboot and it was running fine until the 18.04 upgrade.

12/31/19 After some informing myself about sysrq (reisub) I was able to get the machine to reboot from the error screen.

I attempted to change the 176 sysrq value to 438 using

    # echo "438" > /proc/sys/kernel/sysrq

and make it permanent with

    # echo "kernel.sysrq = 438" >> /etc/sysctl.d/99-sysctl.conf

but it did not change it. Permission denied

    $ cat /proc/sys/kernel/sysrq

Permission granted by using.

    sudo bash

Now returns 438...

So now that I can avoid a hard shutdown what course should I take to resolve the resume from hibernate fail?

My novice status shines.

10
  • I have perused hundreds of possible responses to this problem and none have addressed my error. – nonprophet Dec 31 '19 at 0:34
  • ext4-fs error implies a disk/power/user error likely due to improper shutdown of your system. Are you forcing it off with the power button? Do kernel sysrq keys not work? Did looking in logs provide any clues? "Upgraded to 20" means what? Ubuntu 20.04 doesn't get released until April next year so it's off-topic on this site until then (askubuntu.com/help/on-topic) You also mention a bug, so please provide the bug report (as it'll have information that'll be clearer than your question I hope). Sorry your question is unclear – guiverc Dec 31 '19 at 0:36
  • I apologize for my lack of clarity. As I am a novice I will try to be more specific and answer in order. The system suspends (fan running, screen dark) and resumes normally. Resuming from ibernate on the other hand crashes the system. Whether by reaching the time limit or by closing the lid same result. Seemingly the sysrq keys do nothing at this point and I have to force shutdown with the power button. – nonprophet Dec 31 '19 at 8:05
  • RE: 20 upgrade. during one of the updates I was offered to upgrade to 20 and chose to to see if it fixed this problem. (the term bug is inappropriate apparently?) It did not and I erased the disk and installed 18.04 again from usb. The list of output messages upon resume failure scrolls on until forced shutdown. I let it run for a day to see if it would resolve itself and it did not. – nonprophet Dec 31 '19 at 8:08
  • There are primarily two repeating lines in the output. They are: "[140.803982] EXT4-fs error (device sda1): ext4_find_entry:1455: inode #50202085:comm (e-config): reading directory lblock 0" Whereas the (e-config) portion changes to (plymouth), gmain, system-logind. and "[140.781359] systemd-journald[288]: Failed to write entry (24 items, 586 bytes), ignoring: Read-only file system" This is a journal issue it would seem? I would like to thank you for your time and patience. Again please pardon my lack of clarity and improper vernacular I will try to avoid this in the future. – nonprophet Dec 31 '19 at 8:10
0

Being as this problem did not exist in my old version I have come up with the answer to my question. My solution to this problem is going to be to erase 18.04 and install 16.04. Thanks for all the help.

Update: Problem still exists. Update was not the issue. :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.