9

I am running Ubuntu 19.10 on an old laptop with max resolution of 1366x768.

Is there a way to scale down gnome below 100%? I have already set text scaling to .90 and reduced the dock icon size to 36.

Is this feature available in other window managers?

2

4 Answers 4

4

try with xrandr --output HDMI --scale 0.75x0.75 being HDMI your output from the list xrandr --listmonitors and 0.75 the wanted factor.

4
  • 1
    It makes everything blurry. However if I do the same on Unity Desktop (which supports doing this through a GUI), the scaling works perfectly. Apr 20, 2021 at 11:27
  • 4
    this is corecct: xrandr --output HDMI --scale 1.2x1.2
    – ArMo 372
    Jul 8, 2021 at 6:05
  • @ArMo372 is right the factor has to be more than 1 to generate scale below 100%
    – jave.web
    Feb 23, 2023 at 10:50
  • 2
    displays are overlapping? => solution is apparently to set an offset and auto adjust e.g. for 2 displays/monitors (ltr) left display has original resolution 1920x1080 => 1920x1,2 => 2304: "Left display": xrandr --output DP-1-2 --scale 1.2x1.2 --auto --pos 0x0, "Right display": xrandr --output DP-1-3 --scale 1.2x1.2 --auto --pos 2304x0
    – jave.web
    Feb 23, 2023 at 11:17
2

I'm running Debian 11. I tested this in RockyLinux - which is a CentOS splinter - and it worked.

At a terminal prompt enter:

xrandr --listmonitors

The output will look something like this:

Monitors: 1
 0: +*LVDS-1 3620/309x2036/174+0+0  LVDS-1

In the output the end bit is your video output. In my case it's "LVDS-1"

In a terminal enter:

sudo nano /etc/xdg/autostart/.desktop

Enter the below bit of info changing the LVDS-1 to what ever the output was from your system.

[Desktop Entry]
Type=Application
Name=xrandr
Exec=xrandr --output LVDS-1 --scale 2.65x2.65
OnlyShowIn=GNOME;

Reboot your system and you should be set.

0

There is a bug for this on the Gnome launchpad site, I hope a few more people will go over there and raise it's profile:-

https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1724037

0

I found this while going through the link of the bug issue provided by James Lewis above.

Apparently it was partially implemented in GNOME 42 (Ubuntu 22.04): https://gitlab.gnome.org/GNOME/mutter/-/commit/bfb7151c

  1. Enable fractional scaling in Settings and set it to 100%.
  2. Edit ~/.config/monitors.xml and change the scale value to 0.5
  3. Log in again.

This has worked for me on Ubuntu 22.04.3 LTS, GNOME 42.9.

My primary display is set at 100% and secondary monitor at 80% now.

Thank you Lewis!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .