0

In Ubuntu 18.04 in Settings application I selected Dock from left panel and turned Auto-hide the Dock to On. Dock (the Launcher at the left site of monitor) is now hidden as expected.

There are two ways now to display hidden Dock:

  • I can press Super key to display Dock, I like this.
  • What I don't like is that Dock is automatically displayed when I move mouse to the far left site of monitor. How to disable this "hot" displaying of Dock when moving mouse to left edge of monitor?
0

I figured it out in terminal execute:

gsettings set org.gnome.shell.extensions.dash-to-dock autohide false

Additional notes:

  • get current setting:

    gsettings get org.gnome.shell.extensions.dash-to-dock autohide
    
  • revert to default:

    gsettings set org.gnome.shell.extensions.dash-to-dock autohide true
    
  • there is also an option to install "gsettings" GUI application:

    sudo apt install dconf-editor
    

    and select above (and many more) option by using GUI.

3
  • How does that disable "hot-edge"? What you propose is identical to selecting "Autohide Dock" in settings, and would not prevent the dock from appearing when the mouse cursor reaches the edge. – vanadium Dec 31 '19 at 9:06
  • There are just confusing names between end-user GUI and gsettings property names. In Settings app (turning "Auto-hide the Dock" to on) is actually "org.gnome.shell.extensions.dash-to-dock dock-fixed" setting by default set to true, setting above setting it turns it to false. But lets say "disable mouse hot-edge" is the setting from my answer "gsettings get org.gnome.shell.extensions.dash-to-dock autohide". Confusing names... – folow Dec 31 '19 at 19:25
  • 1
    Indeed I see. Feel free to accept your own answer! – vanadium Jan 1 '20 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.