1

My desktop PC is shared between my spouse and myself. It runs 16.04 LTS and I've set up a keyboard shortcut to execute dm-tool switch-to-user herusernamegoeshere on the F1 key, and this has worked well for some weeks - but since yesterday this seems broken.

It's not (just) that specific command either; the same problem happens when I switch user with the normal GUI approach (click the cog in the upper right corner, then select another user).

What used to happen:
Upon selecting another user, or pressing my custom keyboard shortcut, the screen would go to the other user's desktop, showing whatever was already running for that user. This worked both ways; from either of the two users to the other one. (I had set up the same custom keyboard shortcut on her profile as well.)

What happens now:
The pc normally boots directly into my desktop (this is fine). When I switch to the other user account for the first time, that also works. But switching back to the first does not bring me to my desktop; instead the screen is just all black (but the monitor does not go into sleep mode).

What I've tried:
I can press CtrlAltF1 so see the console, so the machine is not totally frozen. I can sometimes(?!) also press CtrlAltF7 to actually come to my desktop, except there is no launcher, no app bar on the left side, no toolbar at the top, and either no cursor or a black "x" cursor instead of the expected arrow cursor. I do see my desktop icons and files though.

Usually at this point I go to CtrlAltF1 and do a sudo reboot now... but perhaps I can just restart Unity?

I'm not sure where the root cause is. Is it Unity? Is it lightdm? Is it something else?

How can I troubleshoot and pinpoint the cause? How can I resolve this problem?

Updates:

  1. I checked /var/log/syslog and found many rows in the form of
    dconf-CRITICAL **: unable to create file '/home/torben/.cache/dconf/user': Permission denied. dconf will not work properly.
    Indeed that file has 600 permissions and user root:root. I have now set 666 file permissions and chown to my username:group. Now testing whether that makes any differences.
1
  • Did you check your syslog? It can be some useful information there. Also, it seems like a problem with some of the profiles, but I'm not sure. – Taras Khalymon Dec 30 '19 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.