0

I am a bit familiar with linux but I got stucking trying to mount a remote share via CIFS mount.

The remote server is a Zyxel NAS326 and its shares are working under Windows. Under Ubuntu the mount command

mount.cifs //MyNas/drive_p /media/janssen/drive_p -o username=xy,vers=1.0

fails with response

Unable to find suitable address

Neither

smbclient -L //MyNas

is working:

NT_STATUS_CONNECTION_REFUSED

Using file manager (afp) works:

Connection working using file manager

But I want to use cifs mount and if it worked I want to put it into /etc/fstab. Alas it's not even working when trying to mount the share manually (as user root).

Output of dmesg after mount

I could not find any hint for return code -111 . Any help would be appreciated.

Thanks in advance

Uwe

0

Solved (actually kind of workaround):
The actual reason for the connection error was the NAS' sleeping HDD (Zyxel NAS326).

Solution: Wake up the NAS via somehow accessing its HDD (e.g. use the web interface) or do not let it sleep. Then reboot Ubuntu and the mount works.

Note: Without the Ubuntu reboot the mount still does not work (same error code -111). @AtomiX84: Thanks for the hint, but I already looked up the mentioned thread before my post.

Thanks to all reading my question

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.