1

when my video monitor is waking from sleep, audio playback is paused for a second or less, two or three times. the monitor is connected to nvidia card via displayport. there is no problem with hdmi monitors. changing buffers in pulseaudio doesn't help. where I have to dig?

2 Answers 2

0

I am facing this too, actually there are two problems here,

1) sound card is going to power save mode

2) monitor sleep blocks sound due to monitor power save mode

solution for 1.

options snd-hda-intel power_save=0 power_save_controller=N

add this to /etc/modprobe.d/alsa-base.conf

Then restart

As for problem 2.

edit

sudo nano /etc/pulse/default.pa

comment this line like this

#load-module module-switch-on-port-available

restart PulseAudio

pulseaudio --kill; pulseaudio --start
2
  • 1
    I did the suggested actions and nothing changed. It seems that power save is not the issue, since sound card is working (i.e. doesn't sleep) and the issue happens on wake up (not on monitor off). probably the root of the problem that when the monitor is going to power save mode, my active desktop is switching to (console? dummy desktop?), and switching back on wake up. and this process blocks sound for a half of the second. because of my current desktop is lost when I have 2 monitors connected and displayport monitor is turned off (manually), the launcher in moving to hdmi monitor. Commented Jan 9, 2020 at 8:57
  • 1
    probably this is a related bug: bugs.launchpad.net/ubuntu/+source/linux/+bug/1770836 Commented Jan 11, 2020 at 11:25
0

fixed with kernel 5.6 as expected

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .