0

I am trying to setup Ubuntu OS (more specifically Lubuntu) on my Raspberry Pi 4. Firstly, I download the file from IoT page which is specific for Raspberry Pis and then I flash it into the card (which is 16GB with usable 14.8 gb) with balenaEtcher. When it's done it shows confirmation in green and the process is complete (and sdcard is ejected out automatically if that is normal). Then I inserd my SD into the raspberry pi and it starts the process, after that I type in the username and the new password... When it's finished processing the lot I type in "sudo apt install lubuntu-desktop" then it starts processing normally but at the end (or maybe also between) it gives me some failed tasks which are probably the cause for the failure. If I then try to type "startx" it doesn't work and it says that i must install xinit but even when I do it of course doesn't work. Maybe it's because at the end of flashing it makes 2 partitions i think and it then thinks that it doesn't have any space left?

I tried whole bunch of different scenarios like. I downloaded 32-bit, or 64-bit, or tried to install stock ubuntu, and I followed exact steps by the video on YT first one that pops up (and between every attempt I formated SD) but nothing worked. Everything stops at the end. So I would need some help and I would be grateful for your resposes :)

  • What version of Ubuntu are you installing? I heard version 19.10 supports the RPI4. – WinEunuuchs2Unix Dec 29 '19 at 23:07
  • Did you follow a guide? I'm aware Sean Davis' (bluesabre; Xubuntu lead dev) bluesabre.org/2019/10/20/… guide works, including with Lubuntu desktop. I don't have a rpi4, nor does any Lubuntu team member - but we've had users report success after being providing the link I've posted. You didn't mention what release you tried though. – guiverc Dec 29 '19 at 23:30
  • You also didn't say which arch you tried to install. The native for pi4 is arm64, but to use a armhf intended release there were certain adjustments that needed to be done (recorded in lauchpad reports). But you didn't provide any specifics. – guiverc Dec 29 '19 at 23:38
  • I tried to install ubuntu 19.10.1 for raspberry pi 4 which is also specified on Ubuntu website. So, this guide that @guiverc posted can also be used for Lubuntu? I mean, I just want to install Ubuntu basically and not to have the OS eat up majority of my SDcard space xD I wanted to install arm64 – xtremetitan Dec 30 '19 at 9:17
  • Do you need any errors that i get specified? I will try you r guide tho anyways :) – xtremetitan Dec 30 '19 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.