0

I added entries to block the partitions on an external drive (via USB) from auto-mounting at boot time. I tried using the UUIDs, and the block names (/dev/sdc1). (I need to be using the UUIDs.)

UUID=xxxxxxxxxxxxxxxx /media/me/OS ntfs ro,noauto,nofail 0 0  

and separately:

/dev/sdc4 /media/me/OS ntfs ro,noauto,nofail 0 0

If I manually umount the partitions, I can mount them with sudo mount /dev/sdc3 /media/me/OS

sudo mount -a does not remount the partitions.

The drive is a 500GB Seagate Blue. Three partitions are being auto-mounted. The file explorer dialog for each is opening. The dialogs are calling them "volumes." This disk is a copy of a failed disk I recovered with ddrescue.

This question is based on an earlier question I asked, How to Block Automounting of a Specific Drive (USB connection) With ** Three Mounted Partitions **

0

Auto-mounting was enabled in the File Manager (non-standard Thunar mod), and this was overriding /etc/fstab. The setting in the File Manager (Volume Management) is all-or-nothing, mount external drives automatically, or don't. So I disabled that, and am controlling things with udev and fstab.

11
  • Can you expand a little on this? Curious minds want to know :-) I don't see any setting like that in Nautilus File Manager. Are you using something else? What did you do with udev and fstab? – heynnema Dec 31 '19 at 17:27
  • I followed instructions on a post here to change to Thunar some time ago. – JasonF4 Dec 31 '19 at 18:20
  • 1
    Ah, that's why I didn't know about that option. That's not a standard out of the box configuration. I know what you did with fstab. What did you do with udev? – heynnema Dec 31 '19 at 18:31
  • I added a standard udev rule to auto-mount USB drives... – JasonF4 Dec 31 '19 at 19:30
  • I thought that you didn't want auto-mount? Wasn't that the whole point? – heynnema Dec 31 '19 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.