3

I have installed some tools on my Ubuntu 18.04 and apparently something went wrong.

There are a couple of phenomenons.

The first is that Ctrl+Alt+t does not open a terminal. In order for me to open a terminal, I need to right click the desktop and press the "Open a new terminal" button.

Additionally, whenever I run a script that prompts with a question and waits for an answer, the script crashes. For example, the below happens when I run SQLmap:

eliko@ubuntu:~/Desktop/Tools/sqlmap$ ./sqlmap.py -u 
https://nice.app.com/forgot_password?email=rob@bob.com&key=cc
[4] 2652
eliko@ubuntu:~/Desktop/Tools/sqlmap$ 
[!] legal disclaimer: Usage of sqlmap for attacking targets without prior mutual consent is illegal. It is the end user's responsibility to obey all applicable local, state and federal laws. Developers assume no liability and are not responsible for any misuse or damage caused by this program

[*] starting @ 08:46:58 /2019-12-29/

[08:46:59] [INFO] testing connection to the target URL
[08:46:59] [CRITICAL] previous heuristics detected that the target is protected by some kind of WAF/IPS
[08:46:59] [INFO] testing if the target URL content is stable
[08:46:59] [WARNING] target URL content is not stable (i.e. content differs). sqlmap will base the page comparison on a sequence matcher. If no dynamic nor injectable parameters are detected, or in case of junk results, refer to user's manual paragraph 'Page comparison'
how do you want to proceed? [(C)ontinue/(s)tring/(r)egex/(q)uit] Y
bash: Y: command not found

[4]+  Stopped                 ./sqlmap.py -u 

From my understanding, there's both an issue that the process is created in background or something (I'm not a Linux master, but I think because it shows "[4] 2652" and then continues).

The bash: Y: command not found error occurs for any letter inserted including solely hitting ENTER.

I assume the above described set of issues are related to one problem probably caused by tools installations.

I already tried to copy the .bashrc by executing (I saw on some thread this may help):

cp /etc/skel/.bashrc ~/.bashrc

and also tried to restart the machine.

This is the output I get from echoing PATH:

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

What can I do to fix the issue? I cannot use any tool that receives input and seems something is wrong with bash probably.

1
  • 2
    I can suggest to remove "some toolls" that caused all these problems.
    – Pilot6
    Dec 29, 2019 at 17:07

2 Answers 2

9

The issue is likely the & character in your URL - which is causing the shell to place the command in the background (as indicated by the [4] 2652 job number / pid).

Try quoting the URL string:

./sqlmap.py -u "https://nice.app.com/forgot_password?email=rob@bob.com&key=cc" 
3
  • This worked yet im still not able to workout the issue with the terminal open. CTRL+ALT+T does not opens up a terminal. is this related to some issue? Dec 29, 2019 at 18:41
  • 2
    @user3091216 the terminal shortcut issue is unlikely to be related imho Dec 29, 2019 at 19:22
  • Maybe look in your keyboard shortcuts and assign CTRL+ALT+T to the terminal launch xterm or whatever you use.
    – QuickishFM
    Dec 30, 2019 at 11:32
-2

"Y" is not a valid response to
how do you want to proceed? [(C)ontinue/(s)tring/(r)egex/(q)uit]

Choose either C to continue (Normally the uppercase is the default, so a return should also continue). Guessing for the lower case letters:
s stands for a string, which is passed to bash to run as a program (so Y is not a valid program, so, not found).
r stands for a regular expression, expanded then probably treated like a string,
or q stands for the special string "quit"

2
  • I tried many others letters including the above. Same error persists Dec 29, 2019 at 17:23
  • 1
    @ubfan1 in that case the error should come from sqlmap; not bash.
    – vidarlo
    Dec 29, 2019 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.