0

Symptoms:

  • I cannot mount a DVD
  • MakeMKV Failed to get full access to drive . Make sure that you either have write access to device "dev/sr2, are member of "cdrom" group or have CAP_SYS_RAWIO enabled
  • Attempts to manually mount DVD leads to "mount: /mnt/cdrom: no medium found on /dev/sr1."

What I have tried:

  • CD works fine
  • Replaced DVD drive
  • Made sure my user was part of cdrom
  • DVD works fine in OS X
  • Manually mounting the drive
  • Reinstalling 18.04
  • Installing necessary codecs

Any help would be appreciated.

Running groups returns: <myusername> adm cdrom sudo dip plugdev lpadmin sambashare

  • Which order did you do all these things in? What were the actual results of each? What does lshw say about it? – waltinator Dec 29 '19 at 2:15
  • Also, please edit your question and add the output of the command groups from a terminal window. It should show if you are part of the cdrom group or not. – Terrance Dec 29 '19 at 4:32
  • @waltinator lshw shows the this – smykes Dec 31 '19 at 20:03
  • Please edit your post to include new info. Data at the far end of a link doesn't get indexed by AskUbuntu, has a lifetime unconnected to the lifetime of the Question, and helps no future users. – waltinator Dec 31 '19 at 23:57
2

I had the same error message.

In my case, I installed makemkv in Ubuntu by using snap (i.e. by using the Ubuntu Software Store).

To solve the problem, I went into the snap store, clicked on "Installed", scrolled down to the makemkv item, clicked on it, clicked on "Permissions", turned on both of the "Read from CD/DVD" buttons (there were two for me, probably because I have two DVD drives).

I also turned on "Read/write files on removable storage devices" although that may not have been needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.