2

Methods I've already tried:

gnome-tweaks-tool

Fonts -> Antialiasing -> None

~/.fonts.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>false</bool>
        </edit>
        <edit name="rgba" mode="assign">
            <const>none</const>
        </edit>
        <edit name="autohint" mode="assign">
            <bool>false</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hintstyle" mode="assign">
            <const>hintslight</const>
        </edit>
    </match>
</fontconfig>

~/.xsettingsd

Xft/Hinting 1
Xft/HintStyle "hintslight"
Xft/Antialias 0
Xft/RGBA "rgb"

then run xsettingsd

~/.Xresources

Xft.hinting: 1
Xft.hintstyle: hintslight
Xft.antialias: 0
Xft.rgba: rgb 

then run xrdb -merge ~/.Xresources

(took these from here: https://wiki.archlinux.org/index.php/Font_configuration#Incorrect_hinting_in_GTK_applications )

But still some apps do antialiasing, e.g. VLC, Telegram, Viber. How do I disable it there?

Upd. A special case is Evince doc viewer. When it renders PDF, it uses some other settings, other than when rendering its gui (menus, windows etc).

4

I had the same issue in Linux Mint 19.2 with VLC and Chromium not respecting Cinnamon desktop settings for antialiasing or any of the user space configuration options that I wasted a lot of time with. I did eventually find a solution on a clean install of Mint 19.3.

The key was this configuration file:

/etc/fonts/conf.d/10-antialias.conf

When you open it in a text editor you get this:

<?xml version="1.0"?> <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> <fontconfig> <!-- Use the Antialiasing --> <match target="pattern"> <edit name="antialias" mode="append"><bool>true</bool></edit> </match> </fontconfig>

I would assume this file also exists in Ubuntu since Mint is based on Ubuntu.

To disable antialiasing we just need to change the word true to false. You need su permission to edit this file so you can't do it in a text editor in the usual way. Instead, do this:

open a terminal and navigate to /etc/fonts/conf.d

then type sudo nano 10-antialias.conf to open the file in the nano text editor

on the line <edit name="antialias" mode="append"><bool>true</bool></edit>

change the word true to false

hit ctrl o to save your changes and then ctrl x to exit nano and then close the terminal

You may need to sign out and back in or restart for the changes to take effect.

Antialiasing should now be disabled in VLC and Chromium. I don't know about Viber and Telegram because I don't use those apps.

This configuration setting also seems to disable antialiasing system-wide in Mint 19.3. I tried turning antialiasing back on with the Cinnamon desktop setting just to see what would happen and antialiasing remained off so I conclude that this configuration file works on a deeper level than the Cinnamon desktop setting. It also works for Firefox which also doesn't respect the Cinnamon desktop antialiasing settings. I normally disable antialiasing in Firefox by typing about:config in the address bar and setting gfx.text.disableAA to true but that is no longer necessary once the 10-antialias.conf file is modified as above.

1
  • wow! that's fantastic! thank you! that works with vlc, viber, telegram for me (ubuntu 19.10). but unfortunately this doesn't help with evince (doc viewer) – whyer Apr 15 '20 at 9:41
1

I'm glad that worked for you. Your comment about Evince intrigued and bothered me. Just when you think you've cracked something...

I've now found that xreader, the default pdf reader in Mint 19.3, behaves the same as Evince does for you: antialiasing is applied to the document text, irrespective of any system setting for antialiasing with no option in the preferences menu to disable it. Bizarrely, the application menu text follows system settings and does not have antialiasing. There's clearly something different about the way pdfs are rendered but I don't know what it is.

I can't live with antialiasing so I tried all the pdf readers available in the Mint software centre to see if I could find one that had a setting to turn it off and, fortunately, I found one.

It's called qpdfview and should be available in the Ubuntu software centre.

The settings for antialiasing can be found here:

edit->settings->graphics

then click the pdf tab.

3
  • 1
    @Nmath i've just run that qpdfview app and tested it - it works as described by @George45 – whyer Apr 25 '20 at 6:42
  • @George45 thx for such a detailed answer! i didn't even expected that i'll receive such one! :) yes, it works as you described, thx! 👍 – whyer Apr 25 '20 at 6:44
  • @Nmath Noted. I'll check my answers in ubuntu before posting them in future. – George45 Apr 25 '20 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.