3

Recently I connected my external HDD on my Ubuntu 18.04, but it is showing the error

Unable to Access drive-Not authorized to perform operation.

However, my HDD is working fine on windows.
How can I solve this issue?

9

If you happen to have chrome-remote-desktop installed as a Chrome Browser Extension there's a good chance that is the cause of problem.

If so, see Automount when clicking on disks in GUI file manager suddenly stopped working in Ubuntu 18.04 for solution.

1
  • 1
    Thanks! That worked!! As soon as I uninstalled chrome remote desktop I was able to open my external drive. Very unexpected solution for the problem.. – TANMAY JITENDRA AGRAWAL Dec 29 '19 at 5:00
1

Found this answer (not sure where), but it worked immediately.
From commandline

sudo apt autoremove chrome-remote-desktop

Not sure why Chrome RD takes the initiative to control or regulate my OS, so it's gone!

0

Most likely, your drive is formatted with ntfs, the file system of MS Windows. Commonly, problems with access to such partitions is due to the ntfs volume not being "clean", i.e., it was not properly disconnected.

To make sure the disk is clean:

  • Connect it to MS Windows.
  • Have the drive checked using the File System checking tools of MS Windows (consult the manual of your operating system for that).
  • Now fully shut down windows, i.e., no hibernate. Alternatively, properly disconnect the drive using the icon in the notification area.

In Ubuntu, wait until you are logged in before connecting the drive. That will make sure the drive is mounted with permissions for the current user.

You will now be able to access the volume without problems.

Also within Ubuntu, you need to carefully disconnect the drive after use. Either use the right-click option in Files (nautilus) to Eject the drive, or fully shut down Ubuntu before disconnecting the drive.

2
  • I tried the procedure, but unfortunately it doesn't work.. Still seeking the solution of the problem.. – TANMAY JITENDRA AGRAWAL Dec 28 '19 at 16:09
  • I'm not even able to disconnect the drive with 'Safely Remove' drive in Ubuntu. The same error also appears there also. – TANMAY JITENDRA AGRAWAL Dec 28 '19 at 16:12
0

Being in the chrome-remote-desktop group caused the issue for me.

Removing the group from my user account worked after a reboot.

sudo gpasswd -d $USER chrome-remote-desktop

USB sticks and external hard drives were not mounting in Ubuntu 18.04 after using Chrome Remote Desktop. This post https://askubuntu.com/a/1194771/154545 says running the app as a startup application is a work-around.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.