-1

So finally after hours of reading around and listening to tons of advice I found out how to access my account and mount ecryptfs. So okay, I'm closer to my goal of deleting image.img, which is clogging up Ubuntu. Now I'm stuck with a problem. When I go to tmp/ecryptfs, and do rm sdimage.img a it says the filesystem is read only. How can I make my ecryptfs drive read/written?Ubuntu recovery mode attempting to delete the file through root terminal

1 Answer 1

2

ecryptfs-recover-private mounts the decrypted filesystem in read-only mode by default. To get read-write access to your ecryptfs directory, add the read-write option as follows:

sudo ecryptfs-recover-private --rw

This is described at the end of the man page, for future reference. Since you know the location of your path, you can save some time by adding it as follows:

sudo ecryptfs-recover-private --rw /home/.ecryptfs/thomas/.Private

If your volume is still mounted read-only, you will have to unmount your current volume before remounting:

sudo umount /tmp/ecryptfs.LImkydJ6
sudo ecryptfs-recover-private --rw /home/.ecryptfs/thomas/.Private

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .