0

Google Chrome has been reinstalled on a virtual machine running Ubuntu 18.04, however after confirmation of install the icon does not appear in applications or the 'internet' section of the menu bar.

If I run dpkg -l | grep google I see:

'google-chrome-stable' with current version installed ( 79.03945.88-1 ) pulled directly from their download site. 

The interesting thing is I can run sudo /usr/bin/google-chrome-stable --no-sandbox and that pulls up the browser, however I do not wish to run with this flag, as I am wanting this to be opened from the application icon. I tend to place the shortcuts in the system tray.

I uninstalled Chromium as well as Firefox to see if these are also replicating. They are not. Chromium is running fine. The same issue is not replicating with Chrome vs. Chromium.

What started this all you ask? All I can remember is inadvertently clicked and dragged the chrome icon, and never saw the icon / browser again.

I'm not even sure which logs I would look under to tell me more about what is being experienced.

I've tried a few different things, such as removing with apt-get in this order:

  1. Verify installed packages: dpkg -l
  2. Remove package: sudo apt-get remove 'google-chrome-stable'
  3. Purge related code: sudo apt-get purge 'google-chrome-stable'
  4. Autoremove: sudo apt-get autoremove
  5. Clean: sudo apt-get clean

I attempted to reinstall as instructed from 2 Ways to Install Google Chrome on Ubuntu 18.04 LTS Bionic Beaver, but still no icon appears in Applications or 'internet'.

4
  • 3
    Why are you running Google Chrome as root??? Dec 28, 2019 at 3:04
  • 1
    Whenever Google Chrome is installed, a desktop entry is automatically created. Does /usr/share/applications/google-chrome.desktop exists? What are the contents of that file? Is that executable and trusted? Where did you drag the icon? Have you dragged in some folder in app drawer?
    – Kulfy
    Dec 28, 2019 at 10:06
  • Again, I am not purposefully running as root @ajgringo619 I was simply stating that I can use that to start chrome. Big difference. Dec 31, 2019 at 16:04
  • @kulfy The contents of the file after a fresh install through the software mgr. However do note that alot of the Names, Generic Names and other language based entries are not accounted for here as they did not fit for the post. [Desktop Entry] Version=1.0 Name=Google Chrome Exec=/usr/bin/google-chrome-stable %U StartupNotify=true Terminal=false Icon=google-chrome Type=Application Categories=Network;WebBrowser; MimeType=text/html;text/xml;application/xhtml_xml;image/webp;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp; Actions=new-window;new-private-window; Dec 31, 2019 at 16:22

2 Answers 2

2

Step 1: Press Ctrl Alt t to open terminal.

Step 2: Type the command to create a desktop file chrome.desktop

nano ~/.local/share/applications/chrome.desktop

Step 3: Insert the following content into that file:

[Desktop Entry]
Type=Application
Terminal=false
Exec=/usr/bin/google-chrome
Name=Google Chrome
Icon=/usr/share/icons/hicolor/48x48/apps/google-chrome.png

Step 4- Make it executable by running this command:

chmod +x ~/Desktop/chrome.desktop

Step 5- Click on this button

button

3
  • 2
    Step 4 (making it executable) should not be necessary here (unless you're also going to use the .desktop file to launch the application by double clicking).
    – pomsky
    Dec 28, 2019 at 9:58
  • @TejasLotlikar I'm not sure how much me using cinnamon comes into play, but the steps provided did not change anything. Thank you for your help. Dec 31, 2019 at 16:26
  • 1
    Since Ubuntu 18.x defaults to Gnome, you should have mentioned using another DE in your question. Jan 1, 2020 at 16:25
1

I had the same issue on Ubuntu 20.04 LTS: after moving up and down icons on the Dash, the Google Chrome icon was gone (other icons were also missing). I tried to remove and install again google-chrome-stable, but without any success, the icon was not there. I could only start using sudo and the parameter --no-sandbox

I end up removing the /opt/google/chrome directory and running the install again using the instructions on Google Chrome website https://www.google.com/chrome/. The icon was back on Dash and worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.