I'm trying to install the package "intelligent text completition 3.8" for gedit by following this guide:

  1. Unpack the archive
  2. Put intelligent_text_completion.plugin and intelligent_text_completion.py inside .local/share/gedit/plugins in your home directory. (create it if it doesn't exist yet)
  3. (Re)start Gedit.
  4. Go to Edit->Preferences->Plugins and check the box for Intelligent Text Completion

The problem is that I didn't find the box Intelligent Text Completition in Edit->Preferences->Plugins. Can you tell me how can I overcome this problem please?

EDIT: after I installed the gedit-plugins, the available options are the following:

enter image description here enter image description here

EDIT 2: I tried with the command ls -lR ~/.local/share/gedit (idem for ls -alR ~/.local/share/gedit), but the terminal shows me the message "No such file or directory". The strange thing is that I created manually the folders gedit and plugins in the folder .gnome (see the below figure).

enter image description here

Thank you in advance.

  • 1
    Does it show up when you type: ll ~/.local/share/gedit/plugins? I'm wondering if it was unpacked to the wrong place. Dec 27, 2019 at 23:29
  • 1
    Gedit is 3.34 on 19.10. You are installing something that was supposed to work 26 versions ago (gedit 3.8). Last update of that repo is 5 years ago. If I were you, I would find an alternative to gedit if this feature is really needed.
    – dadexix86
    Dec 27, 2019 at 23:34
  • Hello @WinEunuuchs2Unix, as Dk Bose suggests, I forgot to install gedit-plugins. Dec 28, 2019 at 9:29
  • This is the problem: "The strange thing is that I created manually the folders gedit and plugins in the folder .gnome". You should create the gedit folder in ~/.local/share and then create the folder plugins in ~/.local/share/gedit. When you do that correctly, you'll get results for ls -alR ~/.local/share/gedit. Don't put anything into .gnome!
    – DK Bose
    Dec 28, 2019 at 12:55

1 Answer 1


I just tried it on 19.10 and it works for me with gedit 3.34.0 and https://github.com/nymanjens/gedit-intelligent-text-completion/releases/download/v2.4/intelligent-text-completion-gedit3-8-v2.5.tar.gz.

The key point maybe is that you first need to install gedit-plugins from the 19.10 repositories with sudo apt install gedit-plugins.

After doing so, follow the instructions in your link:

Intelligent text completion plugin is listed


This plugin also works in gedit running on Kubuntu 19.10, Ubuntu MATE 19.10 and Xubuntu 19.10.

  • Hi @DKBose, now I installed the geidt-plugins, but the option doesn't appear. See the edit please. Dec 28, 2019 at 9:30
  • Hi @DK Bose I downloaded the right version , i.e. the one you linked above. Dec 28, 2019 at 12:48
  • 1
    So now make sure you put the stuff in ~/.local/share/gedit/plugins. Also please post the output of ls -alR ~/.local/share/gedit/plugins. The plugin even works in Ubuntu Mate 19.10.
    – DK Bose
    Dec 28, 2019 at 12:50
  • thank you very very much; finally it appears! Dec 28, 2019 at 13:01
  • You're most welcome!
    – DK Bose
    Dec 28, 2019 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.