I am trying to turn on Automatic Date & Time but it turns off immediately on its own.

enter image description here This seems to happen only after installing the latest updates.

How do I enable Automatic Date & Time?

  • Just to make sure, it says "requires internet access". Is your system connected to the internet?
    – pomsky
    Dec 27 '19 at 8:39
  • @pomsky Yes. It is connected. I posted the question and this comment from the same system. :) Dec 27 '19 at 8:41
  • @AksharPatel for instance you can update your time from terminal: sudo ntpdate time.nist.gov for timezone update: sudo dpkg-reconfigure tzdata
    – kamil
    Dec 27 '19 at 8:49
  • @AksharPatel and check if you have ntp enabled: sudo apt-get install ntp
    – kamil
    Dec 27 '19 at 8:52
  • 3
    Experiencing same issue, reported bug: bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/…
    – Grant
    Jan 2 '20 at 12:26

Short answer:

$ sudo apt remove ntp

And try to enable automatic Time & Date again.

Long answer:

If you try to start the "systemd-timesyncd" service manually with:

systemctl start systemd-timesyncd.service

and check the status with:

systemctl status systemd-timesyncd.service

you can see that it says:

Condition: start condition failed at <some time>; 1s ago
       └─ ConditionFileIsExecutable=!/usr/sbin/ntpd was not met

So "ntpd" has to be unavailable in order for this to work. If you check the file "/lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf" you can see some more conditions that prevent the start:


So depending on your installation it will also stop working if "ntp", "openntpd", "chrony" and/or VirtualBox Services are installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.