1

I have installed LightBurn on Ubuntu. They do not have a full installer for Linux. I run the application by clicking on the .AppImage file on my desktop.

While the application is running, the icon appears in the Dock. I want it to stay there when it is closed. When I right click on the LightBurn icon a menu pops-up with:

  • All Windows > (image of LightBurn windows)
  • Quit

If I click 'Show Applications', LightBurn does not appears in that list.

How do I get it in the dock?


Ubuntu 18.04.3.LTS

1

Follow the steps below.

  1. Create a .desktop file, say lightburn.desktop, in ~/.local/share/applications. You can do that by running the following command in Terminal:

    touch ~/.local/share/applications/lightburn.desktop
    
  2. Open the .desktop file with a text editor of your choice. For example, to open with the default text editor, run

    gedit ~/.local/share/applications/shutdown-for-dock.desktop
    
  3. Add the following lines to the .desktop file it and save it.

    [Desktop Entry]
    Comment=Short description of the application
    Terminal=false
    Name=LightBurn
    Exec=/full/path/to/the/AppImage-file
    Type=Application
    Icon=/full/path/to/icon/image
    
  4. Click Activities or Show Applications and search for "LightBurn". It should appear now.

  5. Right click and mark as favourite.
    If right clicking doesn't show an "Add to favourites" option, search for the application in Activities screen, and then drag it across to the dock.

| improve this answer | |
  • Ok got that working. Now when I start the application, I get 2 icons in the Dock. Other applications don't do this. Any way to get that? – Al Lelopath Dec 26 '19 at 0:02
  • 1
    @AlLelopath That should be fixed by adding a proper StartupWMClass line in the .desktop launcher, refer to this. – pomsky Dec 26 '19 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.