Terminal font has been changed

why has the font of my terminal been changed?

1 Answer 1


It's not your fonts, it's your system locale. run locale to get your current locale configuration.

You can use something like LC_TIME=fr_FR ls -l to get France's format in date column as an example if it's available to use on your system.

You can also use locale -a to get a list of available locales. edit /etc/locale.gen file to enable your desired locales by removing # from any line you want, then run sudo locale-gen to generate them.

After all run:

sudo localectl set-locale LANG=en_US.utf8

to set English locale as your default or change en_US.utf8 with your desired locale.

  • It would be more interesting to list the current locale setting first and then change it.... Dec 25, 2019 at 1:50
  • Upvoted but I meant if you type locale all by itself it lists the current settings. Dec 25, 2019 at 1:56
  • 1
    In that case Merry Christmas! It's Christmas eve here. Dec 25, 2019 at 1:59
  • @WinEunuuchs2Unix and Ravexina Merry Christmas!
    – DK Bose
    Dec 25, 2019 at 4:32
  • 1
    @DKBose Merry Christmas and welcome back to your old name :) Monica's progress with SE is an early Christmas present for you. Dec 25, 2019 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.