1

Merry Christmas friends!

Spent about 5 hours to find a solution to this issue, and i'm about to go nuts..

I followed this guide to created a split tunnel, and assigned the tun0 to a "vpn" user in Ubuntu. Which actually works, I logged into the user and did a curl ipinfo.io to test the vpn connection. So the split tunnel works just fine.

The qBittorrent is accessible when i use my regular user in the qBittorrent-nox.service file.

But not when I replace my regular username with "vpn". I suspect it's permission issues, but I did add the vpn user to sudo group, my regular user to the vpn group.

When I do a curl localhost:8080, I get this

I tried my very best to get this working, but I really don't know what to do now...

  • "When I do a curl localhost:8080, I get this" - Is this with qBittorrent running under the vpn user? That looks like it's working properly, unless it's not accepting the password or something (?) - is that the case, or do you just get an "unable to connect" in your browser? I don't know the answer to your question, but, once you do get it running, there is a magnet link at https://ipleak.net/which you can load into your torrent client to verify that VPN is working in the torrent client, in case you want to check. – JonasCz - Reinstate Monica Dec 24 '19 at 19:21
  • The browser tells me it's unreachable. Tried with chrome, firefox etc. When I change it back to my regular user, I have access to the web interface without issues. – Runar G Dec 24 '19 at 20:42
0

Yay, Got it working! Seems like the problem was within the iptables.sh file.

I changed the:

export LOCALIP="192.168.1.60"

to

export LOCALIP="192.168.1.0/24"

Which makes any devices within 192.168.1.0 subnet, able to reach the Web UI.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.