I can't make work the multitouch of the ALPS touchpad in my Dell Inspiron I15RN-3647BK with Ubuntu 11.10 x64, kernel 3.0.0-17-generic... I have tried with this driver but it doesn't work http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.10/psmouse-alps-dkms_0.10_all.deb. This is the result from the following command:

user@laptop:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD               id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys 

That came with or without the alps driver from canonical repository and the touchpad just works like a PS2 generic mouse...

Any ideas?

Thanks in advance...


Just didn't want to take credits for solving that problem. I did everything it said in that blog. Here's what I did in the terminal:

1. wget -O psmouse.tgz http://www.dahetral.com/public-download/psmouse-alps-dst-0.4.tbz/at_download/file
2. tar -xvf psmouse.tgz
3. cd usr/src/psmouse-alps-dst-0.4/src/
4. wget -O alps.c http://pastebin.com/raw.php?i=m404GW1G
5. cd ../..
6. sudo mv psmouse-alps-dst-0.4 /usr/src/
7. cd /usr/src/psmouse-alps-dst-0.4/
8. sudo dkms add psmouse/alps-dst-0.4
9. sudo dkms autoinstall
10. sudo rmmod psmouse && sudo modprobe psmouse
  • When I got to 10 it complained about psmouse module not existing so I did 9 again and just sudo modprobe psmouse and multitouch was already working. Then I rebooted and did 9 and 10 again because the touchpad had a lag and moved really slow. Don't know exatly what solved that but it's working great now.
  • I did all that and it didn't work. The DKMS install finishes, but there are two errors shown: ERROR (dkms apport): kernel package linux-headers-3.2.0-23-generic is not supported Error! Bad return status for module build on kernel: 3.2.0-23-generic (x86_64) Consult /var/lib/dkms/psmouse-alps/0.10/build/make.log for more information. I have Ubuntu 12.04, maybe that has something to do with it. What is your laptop configuration exactly? Oct 19 '12 at 10:45
  • Judging from the error you received it definitely looks like it has to do with installing on Ubuntu 12.04. It says the kernel version is not support (too old) so i'd try either upgrading to 12.10 or installing newer kernel. Oct 22 '12 at 13:41
  • I updated the kernel and followed the steps you mentioned. The 2 finger scroll works fine now. It seems though that the touchpad's sensibility is affected, in the sense that I cannot move the cursor as 'easily' as before, and a vertical strip near the right of the touchpad doesn't work. Still, it is a great improvement to be able to use the scroll. It seems that disable tap-to-click works fine also. Oct 23 '12 at 15:28
  • I recently switched to kde. The synaptiks aplication can fine tune sensitivity, and it works much better. You can try sudo apt-get install synaptiks, I don't know if it'll work, or you can install kde using sudo apt-get install kubuntu-desktop. Oct 31 '12 at 22:38
  • The download link is broken, there is a new version here github.com/emmanuelthome/psmouse-alps
    – alfC
    Jul 6 '13 at 5:48

This solved it for Dell Inspiron N5110 on Ubuntu 12.10. Just follow the instructions on this site, which has extracted the instructions from this arch forum thread.

  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Peachy
    Oct 12 '12 at 10:58
  • 1
    Did you do exactly all that it is said there? Is there any other software you installed before you used the instructions? I tried them but they do not work for me. Oct 12 '12 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.