0
admin1@admin1-VirtualBox:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.3 LTS
Release:    18.04
Codename:   bionic

Installed Fresh Ubuntu 18.04.3 LTS as mentioned above on Oracle VM Virtual Box Manager (Oracle VM Virtual Box Manager installed on Windows 10) having issue connecting with Putty on port 22. ssh server is already running and tried disabling firewall but no success.

enter image description here enter image description here

The, /etc/netplan/, directory has file with name,

admin1@admin1-VirtualBox:/etc/netplan$ sudo nano 01-network-manager-all.yaml

and contents,

# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager

Command output for - ifconfig

admin1@admin1-VirtualBox:/etc/netplan$ ifconfig
enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.2.15  netmask 255.255.255.0  broadcast 10.0.2.255
        inet6 fe80::1861:58f3:5ae4:1e5  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:04:b3:e6  txqueuelen 1000  (Ethernet)
        RX packets 5281  bytes 3827866 (3.8 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3392  bytes 766694 (766.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 589  bytes 49015 (49.0 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 589  bytes 49015 (49.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

How to connect to Ubuntu from Putty on Windows 10. Please help, I have spent several hours with this and I am new to Ubuntu.

  • Do you have an SSH server installed on your Ubuntu machine? Is the SSH server started? Are you able to ping your Ubuntu machine from Windows? – Mukesh Sai Kumar Dec 23 '19 at 16:03
  • 1
    How did you test that VirtualBox networking is working as expected? – user535733 Dec 23 '19 at 17:47
1

From what I see, I assume that when you configured networking for your Virtual Machine, you chose NAT. NAT allows your VM to connect to the Internet, but it doesn't allow your Host to connect to your Guest. If you want that functionality, choose Host-Only in VirtualBox.

  1. Shut down your Ubuntu VM.
  2. From Preferences in VirtualBox, create a new Host-Only network.
  3. From the VM Settings for your Ubuntu machine, change the network type from NAT to Host-Only.
  4. Ensure that the chosen network is the one you created earlier.
  5. Start your Ubuntu VM.
  6. Note the IP address now, and try logging in with PuTTY.

For more details, refer here.

| improve this answer | |
  • Thanks it helps. – Sharad Dec 23 '19 at 18:03
  • Always glad to help :) – Mukesh Sai Kumar Dec 23 '19 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.