1

I had Windows 10 on my Acer aspire ES14 (1T hdd, 4Gig RAM, Intel celeron N3350), but due to the latest update, it created a conflict where the update would happen, but not complete, and that would create a 100% disk usage problem.

After repeated re-installs, it led to re-installation problems with Windows recovery.

So I decided to rather install Ubuntu. I was a novice wrt Ubuntu and clueless. I have since learnt a little bit.

I installed Ubuntu 19.10 as a single boot, thus wiping the hard drive completely. All went well with the installation, and when asked to restart and remove the installation media (live usb drive), i found the message appearing, no bootable device.

I have tried using UEFI to address the issue: 1. I disabled SECURE BOOT and even re-installed ubuntu (a clean install, wiping the hard drive again), but this still shows no bootable device. 2. I attempted to switch to LEGACY, but do not have the feature that allows such a switch. Basically i'm stuck in UEFI.

I ran a boot info, and as follows, is the report: http://paste.ubuntu.com/p/pt7j7wzYsH/

Basically I can only use Ubuntu, by leaving the live USB in, which gives limited functionality.

Please can anyone help me to ensure Ubuntu loads directly from the HDD? Please include step by step instructions as Im still very new to this, and even copying boot loader files to the ESP leaves me bewildered...

Paul

3
  • 1
    Did you try grub-install from a live boot on USB? – Mukesh Sai Kumar Dec 23 '19 at 15:38
  • 1
    Hi there, thanks for the response, apologies for such a late reply, i thought i might get a notification of a reply, but didn't. I had the page open also, but didnt somehow see your reply. Apologies again. I Am really new to this forum. Im not sure what the grub installer is, but will look it up on the forum and then refer back once I've figured it out and tried it. – Paul Jacobus Dec 24 '19 at 11:00
  • Hi, I think I have used the correct method. I used the terminal command to repair GRUB2 via the live USB, I 1st identified the partition Ubuntu is installed on-it was SDA2. I then mounted the partition. I then ran the following command to re-install GRUB on the harddrive: sudo grub-install --boot-directory=/mnt/ubuntu/boot /dev/sda. The feedback i received is that an error occured, as follows: 1. The GPT partition contains no BIOS boot partition. 2. Embedding is not possible, GRUB can only be installed using blocklists which is not recommended. Any other suggestions? – Paul Jacobus Jan 1 '20 at 14:20
1

The problem appears to be this, from lines 570-579 of your Boot Repair output:

=================== efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,2002,2003
Boot0000* Unknown Device:   HD(1,GPT,0d8e467f-f6a9-4029-a832-f87387ec93df,0x800,0x100000)/File(EFIubuntushimx64.efi)RC
Boot0001* USB HDD: Generic Flash Disk   PciRoot(0x0)/Pci(0x15,0x0)/USB(2,0)/HD(1,MBR,0x94cd578,0x800,0xf40800)RC
Boot0002* ubuntu    HD(1,GPT,0d8e467f-f6a9-4029-a832-f87387ec93df,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC

Basically, your computer's boot order (BootOrder: 20001,20002,20003) includes only the USB device (Boot2001), the optical drive (Boot2002), and the network (Boot20003). To boot Ubuntu, the boot order must be amended to include the ubuntu item (Boot0002). There are several ways this can be done. The three easiest are likely:

  • From the firmware
    1. Boot into the firmware setup tool.
    2. Locate the option to change the boot order.
    3. Add the ubuntu item to the boot order. (Details of how to do this depend on the firmware implementation, so I can't be more specific.)
  • From Ubuntu
    1. Boot an Ubuntu installation/recovery/emergency disk in EFI mode. (Your Jan. 1 comment reveals that you booted at least one recovery attempt in BIOS/CSM/legacy mode -- see here for details on the perils of the CSM.)
    2. Open a Terminal window.
    3. Type sudo efibootmgr -o 0002,2001,2002,2003.
    4. Reboot.
  • Using Boot Repair
    1. Boot the Boot Repair tool in EFI mode (see the caveat above about not using BIOS/CSM/legacy mode).
    2. In the Boot Repair tool, use the option to repair the boot process.
    3. Reboot.

There is one very big caveat: Some computers, especially from a few years ago, have very buggy EFIs. Yours may be one of them. Such computers may ignore attempts to adjust their boot order. On such computers, you may be left having to cope by using some hackish workaround, such as installing a Linux boot loader using the filename normally used by a Windows boot loader (EFI/Microsoft/Boot/bootmgfw.efi) or by the default/fallback boot loader (EFI/BOOT/bootx64.efi). IIRC, Boot Repair has an option somewhere to make this adjustment, but I don't recall precisely where it is, offhand. Since you've already run Boot Repair, you've either neglected to actually use its option to repair the boot process or your firmware is afflicted by this problem.

6
  • Acer has a unique requirement of setting "trust" on anything other than "Windows Boot Manager". You do show one entry with "ubuntu" but other as "unknown" which is typical of not having set trust. Acer Aspire E15 will not dual boot, many details Trust settings in step 35 askubuntu.com/questions/627416/… & Acer Trust Settings - details, some now report that then secure boot has to be on to set trust: ubuntuforums.org/… – oldfred Jan 7 '20 at 21:42
  • @rod, I tried using the three suggestions, and here is my feedback: 1. firmware= Sadly was a no go. I cannot post a pic of the boot order i have on ACER sadly. But I tried all the options and no luck. 2. From Ubuntu=I think I did it correctly. Does booting the Live USB in EFI mean basically sticking the Live USB in? Not sure what booting in EFI means sadly. But this did not recognize the command u gave. 3. Boot repair= i have used boot repair before, and sadly it hasnt worked. I tried it now too. Still no luck. How would I install a linux boot loader as you suggest lastly? – Paul Jacobus Jan 9 '20 at 8:22
  • @oldfred, If I understand correctly, I do not have the step 35 available which you mention. I do not have the "Select an UEFI file as trusted for executing" option. – Paul Jacobus Jan 9 '20 at 8:32
  • Many systems that did not have setting then needed UEFI update from Acer. You do have to have Secure Boot on and set a UEFI password to open up or enable additional settings. Never lose that password or reset to blank when done. Your sudo efibootmgr -v as shown in Boot-Repair report is boot order. You should see that in UEFI also. – oldfred Jan 9 '20 at 12:36
  • @oldfred. If I understood you correctly, I have attempted to do the update to my UEFI. However, the UBUNTU programmes would not open the updates available on ACERs website. I imagine they are only windows compatible? Acer only gave the option for windows 10 updates. I am now trying to reinstall windows. However, it seems, in order to do a new install, my harddrive needs to be in NTFS, and its not. Do you recommend formatting my drive to re-install windows? Im using the media creation tool of windows 10. – Paul Jacobus Jan 13 '20 at 14:57
0

I have Acer Aspire ES 14 laptop. After trials & errors, I found out that in your EFI folder must have "LINUX", not ubuntu, not other names. So what you need to do are:

  1. Bootup using live ubuntu and use DISK UTILITY to mount your EFI partition.
  2. Rename ubuntu folder to LINUX.
  3. Go LINUX folder, copy grubx64.efi and paste as another file.
  4. Rename that copy as bootx64.efi.
  5. In same folder, make sure UUID in *.cfg is referring where your ubuntu partition is.
  6. Reboot.

Hope it help. Remember to disable SECURE BOOT in BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.