6

When I try to ssh from my Ubuntu Desktop to Raspberry pi, It throws the error "Too many authentication failures" and dies, and does not prompt me for the password

1 Answer 1

10

After enabling the -v verbose option I found that my SSH client is trying out all available ssh keys stored locally to try and connect to the raspberry pi and then gives up.

Since I want an interactive login (be able to enter the pi/raspberry password manually) when trying to SSH to my raspberry pi, I had to add the following entry to ~/.ssh/ssh_config

Host 192.168.1.10
           PreferredAuthentications=password

Note: 1) IP address mentioned above is that of my Raspberry Pi. 2) If you are using an SSH key to login (which you should ideally), you wont need this.

1
  • 9
    Quick solution: ssh -o PreferredAuthentications=password <hostname_or_ip>, which sets the option for that single connection. Once connected you can add your key as appropriate, and SSH should work fine after that. Commented Feb 3, 2020 at 7:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .