0

I'm attempting to upgrade to 19.10 from the 18.04 LTS but have encountered some blockages. I followed the instruction to change the line in release-upgrades then on trying got a message in the console that "Upgrades to the development release are only available from the latest supported release."

I then used the upgrade-manager (Alt F2), followed the instructions and got upgraded to 19.04. However a second attempt with the result shown in this image, confirmed that there is a 19.10 upgrade but I have no luck installing it. Photo

Attempts via the terminal:

"mark@mark:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.04
Release: 19.04
Codename: disco
mark@mark:~$ sudo do-release-upgrade -d
[sudo] password for mark:
Checking for a new Ubuntu release
Upgrades to the development release are only
available from the latest supported release."

I'd appreciate any help in getting over this hump.

Thanks.

  • 1
    Hint: What do you expect the -d flag to do? – user535733 Dec 22 '19 at 0:37
  • I'm following the instructions at wiki.ubuntu.com/EoanErmine/ReleaseNotes/UbuntuStudio – Mark Lee Dec 22 '19 at 6:00
  • That instruction was mistaken - it should not have included the -d flag. Thank you for the link, I have corrected the mistake. You have contributed to a better Ubuntu! – user535733 Dec 23 '19 at 5:34
0

The problem was solved by using apt update rather than apt-get update. Apt showed that a Calf-plugin package needed to be upgraded. Apt-get did not show that information. Installing the calf-plugin update solved the problem.

|improve this answer|||||
  • Correlation, not the real cause. The real cause of the problem in your original question was use of the '-d' flag, which tells the system to upgrade to the development release (currently 20.04), not the most recent release (19.10). – user535733 Dec 23 '19 at 5:33
  • Aah. Thanks for that info. However, no option was successful--with -d or without--until I followed the instruction in the console with regards updating Calf-plugin. So yes, on the one hand, with -d was attempting to upgrade to the development release, while on the other, without that flag there was another obstacle to the upgrade. Thanks. – Mark Lee Dec 24 '19 at 21:49
  • So you had two separate, unrelated issues to correct. Needed to make that clear for future readers. Your specific pair of issues is unlikely to affect most other users. – user535733 Dec 24 '19 at 21:55
  • ...Also, as per the image in the original post, the Software Updater route was not successful since it showed that 19.10 (Ubuntu Studio/Ubuntu) was available but I got no feedback on why the Upgrade command using the button didn't give the desired result. apt-get did not provide the detailed comments that apt did. i.stack.imgur.com/8dxg1.png – Mark Lee Dec 24 '19 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.