1

I am on Ubuntu 18.04.3 LTS, and the computer freezes after I enter in my login information.

I have looked thoroughly at the solutions presented on Ubuntu gets stuck in a login loop but none of them work for me. I changed the ownership on ~/.ICEauthority and I don't have a ~/.Xauthority

I am using gdm3, not lightdm. I switched to lightdm, but then uninstalled it.

Now I cannot install gdm. Package 'gdm' has no installation candidate. What?! I've also tried gdm3 which doesn't appear to exist either. Solution here How do I switch from LightDM to GDM? doesn't work

per Freeze after login Ubuntu 18.04 I tried sudo add-apt-repository ppa:graphics-drivers/ppa I get errors that this bionic Release does not have a Release file.

as suggested on other pages, I've done sudo ubuntu-drivers devices which outputs

==sys/devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.1 == modalias: usb:....... vender: Realtek Semiconductor Corp. driver : rt18812au-dkms - distro free

the output of apt-search gdm3 is that I have gdm3/bionic-updates,bioinc-secuirty, now 3.28.3-0ubuntu18.04.4 amd64 [installed] GNOME Display Manager

output of sudo apt-get check shows no problems.

output of sudo lshw -C memory:

*- firmware
 description: BIOS
 vendor: LENOVO
 physical id: 0
 version: 3JCN19WW
 date: 08/10/2016
 size: 128 KiB
 capacity: 6016KiB
 capabilities: pci upgrade shadowing cdboot bootselect edd int13floppynec int13floppytoshiba int13floppy360 int13flopppy1200 int13floppy720 int13floppy2880 int9keyboard int10video acpi usb biosbootspecification uefi
 *-cache: 0
 description: L1 cache
 physical id: 5
 slot: L1 cache
 size: 128KiB
 capacity: 128KiB
 capabilities: synchronous internal write-back unified
 configuration: level=1
*-cache: 1
 description: L2 cache
 physical id: 5
 slot: L1 cache
 size: 512KiB
 capacity: 512KiB
 capabilities: synchronous internal write-back unified
 configuration: level=2
*-memory
 description: System Memory
 physical id: 24
 slot: System board or motherboard
 size: 8GiB
 *-bank:0
  description: SODIMM DDR4 Synchronous 2133 MHz (0.5ns)
  product: M471A5244BB0-CPB
  vendor: Samsung
  physical id: 0
  serial: 00000000
  slot: ChannelA-DIMMO
  size: 4GiB
  width: 64 bits
  clock: 2133MHz (0.5ns)
 *-bank:1
  description: SODIMM DDR4 Synchronous 2133 MHz (0.5ns)
  product: M471A5143EB1-CRC
  vendor: Samsung
  physical id: 1
  serial: 974F4E14
  slot: ChannelB-DIMMO
  size: 4GiB
  width: 64 bits
  clock: 2133MHz (0.5ns)
*-memory UNCLAIMED
 description: Memory controller
 product: Sunrise Point-LP PMC
 vendor: Intel Corporation
 physical id: 1f.2
 bus info: pci@0000:00:1f.2
 version: 21
 width: 32 bits
 clock: 33MHz (30.3ns)
 capabilities: bus_master
 configuration: latency = 0
 resources: memory:bi224000-bi227fff

output of free -h

        total   used   free   shared   buff/cache   available
Mem:     7.7G   355M   6.8G      106M       574M      7.0G
Swap:    7.9G     0B   7.9G

now I'm totally stuck. How do I get my Ubuntu back?

  • Please run sudo apt update and then provide the output of apt search gdm3. Additionally, sudo apt-get check will check for broken dependencies, do you get any relevant output from that? – ofperfection Dec 21 '19 at 22:33
  • A freeze is NOT a login loop. Solutions to the latter will not usually help you with the former, – user535733 Dec 21 '19 at 22:36
  • First... STOP! The frantic steps that you've taken are only doing damage to your Ubuntu installation. Current status please. Are you able to log into your account using gdm3? If so, edit your question and show me ls -al ~/.local/share/gnome-shell/extensions. Report back. Start comments to me with @heynnema or I may miss them. – heynnema Dec 21 '19 at 22:51
  • @heynnema the directory you mention doesn't even exist, it only goes to ~/.local/share/gnome-shell/ – con Dec 21 '19 at 23:29
  • @ofperfection apt search gdm3 shows that it is installed (?) and apt-get check shows no problems – con Dec 21 '19 at 23:30
0

Amongst other possible repairs required...


We need to test your memory.

Go to https://www.memtest86.com/ and download/run their free memtest to test your memory. Get at least one complete pass of all the 4/4 tests to confirm good memory. This may take many hours to complete.


Your BIOS is very old.

Note: have a good backup before updating the BIOS

Lenovo Ideapad 310-15IKB

You have BIOS version 3JCN19WW, and 3JCN31WW is current. See...

https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/300-series/310-15ikb/downloads/ds118500

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.