0

So I have this problem on both my Ubuntu 18.04. (On Thinkpad X1 Carbon 7th Gen) and my Ipod Touch 7. On both systems I can connected to my Speedlink 5501 Router via Wifi, but apparently only Google works. If I enter e.g. askubuntu.com, I do not get a connection. All other devices in the network work fine.

I am getting this strange behaviour:

max@max-ThinkPad-X1-Carbon-7th:~$ ping 8.8.8.8
connect: Network is unreachable
max@max-ThinkPad-X1-Carbon-7th:~$ ping google.com
PING google.com(fra16s14-in-x0e.1e100.net (2a00:1450:4001:81a::200e)) 56 data bytes
64 bytes from fra16s14-in-x0e.1e100.net (2a00:1450:4001:81a::200e): icmp_seq=1 ttl=57 time=11.8 ms
64 bytes from fra16s14-in-x0e.1e100.net (2a00:1450:4001:81a::200e): icmp_seq=2 ttl=57 time=14.1 ms
^C
--- google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 11.817/12.974/14.131/1.157 ms
max@max-ThinkPad-X1-Carbon-7th:~$ ping askubuntu.com
connect: Network is unreachable

I cannot even ping my router at 192.168.100.1, nor access the webinterface.

I first thought that it could be a DNS problem, but changing DNS (i.e. adding additional IPs) won't help. How could I resolve the problem? I think, given that many devices in my network work but both the Thinkpad and the Ipod do not work, this is somewhat strange.

The following output might be useful:

max@max-ThinkPad-X1-Carbon-7th:~$ ifconfig
enp0s31f6: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether f8:75:a4:08:16:da  txqueuelen 1000  (Ethernet)
        RX packets 4810  bytes 5092583 (5.0 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3726  bytes 420311 (420.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xea200000-ea220000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 2341  bytes 210190 (210.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2341  bytes 210190 (210.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp0s20f3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::9418:a3d9:4ff1:e94c  prefixlen 64  scopeid 0x20<link>
        inet6 fde2:8acd:e9d3:0:429a:b26:8370:18ce  prefixlen 64  scopeid 0x0<global>
        inet6 2003:ec:3730:f00:c26b:1148:c6c6:b07c  prefixlen 64  scopeid 0x0<global>
        ether 94:e6:f7:06:76:97  txqueuelen 1000  (Ethernet)
        RX packets 3674  bytes 1519570 (1.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3531  bytes 605307 (605.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

max@max-ThinkPad-X1-Carbon-7th:~$ iwconfig
lo        no wireless extensions.

wlp0s20f3  IEEE 802.11  ESSID:"ZYXEL-133"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 04:BF:6D:55:0F:0E   
          Bit Rate=86.7 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=47/70  Signal level=-63 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:458   Missed beacon:0

enp0s31f6  no wireless extensions.

The command "ip route show" does not yield anything. Also, I tried connecting to the router directly via Ethernet, resulting in the same problem.

Any help is appreciated! Thanks

1
  • You're not getting an ipv4 IP address. Power cycle your router.
    – heynnema
    Dec 21 '19 at 15:29
2

Try disabling the ipv6 address. Go to network settings and uncheck the "IPv6".

https://linuxconfig.org/how-to-disable-ipv6-address-on-ubuntu-18-04-bionic-beaver-linux

Google is probably reachable with IP v6. You do not seem to have an ipv4 assigned.

1
  • This apparently does not solve the problem. For some reason I am able to access the URL you posted after disabling IPv6, but other websites still do not respond. Ping does not work after disabling IPv6.
    – Doc
    Dec 21 '19 at 15:17
0

Disabling IPv6 did not solve the problem, but it has put me on the right track, thanks!

The solution was to manually assign a static IPv4 address, apparently my router's DHCP doesn't work as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.