0

I did the following in a terminal to get a AC1200 Linksys Wireless adapter to work on my Ubuntu 19.10 install:

sudo apt-get install linux-headers-$(uname -r) linux-headers-generic build-essential git
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux
cd rtl8812AU_8821AU_linux
make
sudo make install

This process went through without errors and install was completed. However, my wireless USB adapter still doesn't work. I ran lsusb in terminal and my wireless adapter was listed as

Bus 002 Device 004: ID 13b1:003f Linksys WUSB6300 802.11a/b/g/n/ac Wireless Adapter [Realtek RTL8812AU]

I then ran the following, and it simply returned the command line prompt

modinfo 8812au | egrep -i 'versi|filen|003f'
sudo modprobe -v 8812au
iwconfig
iwlist chan

When I opened my network setting for WiFi, I received the following:

No WiFi Adapter found
Make sure you have a wifi adapter plugged in and turned on

I also tried to get it to work by installing ndiswrapper, but that didn't work either. I have researched this and have tried numerous things I found, but nothing seems to work. I know this has been answered before, but the answers all indicate the above procedure. Any help is appreciated as I am new to Ubuntu, but have run Red Hat linux prior to its shifting to Fedora.

2
  • I apologize that the commands all ran together. I am new at this and will do better next time. – nhigh Dec 21 '19 at 1:32
  • 1
    See askubuntu.com/questions/642794/… and use the dkms installation instructions, – heynnema Dec 21 '19 at 15:05
1

For Linksys WUSB6300 do this:

Make sure USB wireless device not inserted

  1. Update the system:
    $ sudo apt update

  2. Install required packages:
    $ sudo apt install git && build-essential

  3. Download the driver:
    $ sudo git clone https://github.com/gnab/rtl8812au

  4. Go to the directory:
    $ cd rtl8812au

  5. Do the next commands consecutively:
    $ sudo make clean
    $ sudo make
    $ sudo make uninstall
    $ sudo make install

Reboot and insert USB wireless stick

-Persists reboots
-Works with dlink dwa-182 and linksys WUSB6300

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.