5

Let me tell you my problem: I just move from Windows 7 to Ubuntu and I'm trying to setup my programming environment. I installed Eclipse via Ubuntu Software Center, then opened it and installed additional plugins.

Problem came up when I tried to install Subclipse: according to the official guide, I installed JavaHL, but that damned library wasn't automatically linked by Eclipse, so I was told to "Note that JavaHL does not install in a location that is on Eclipse's default path, so eclipse must be launched with -vmargs -Djava.library.path=/usr/lib/jni".

Yes I know I have to modify eclipse.ini and add that vmargs line, but where is eclipse.ini??? I opened /usr/bin, the eclipse.exe is there but I can't found the rest.

I really don't want to remove this Eclipse and download another from Eclipse download page, because I will have to reinstall every plugins again. Please can anyone tell me how to find the directory which contains software which installed via USC? Any help will be appreciated.

6
  • 1
    You won't find your files in /usr -- that belongs to the root (the system). Programs may be stored there, but not the settings. Unlike Windows, Linux stores user files in each user's own home folder, so that no two users can interfere with each other. Look in your own home folder. The .ini file will probably be in a hidden folder, e.g. .eclipse (note the leading dot). Open Nautilus (your file manager) > View > Show Hidden Files (or press Ctrl-H) to see your hidden folders and files. Commented Apr 7, 2012 at 16:47
  • 1
    Goto usr/share/applications you can see installed apps there
    – Tachyons
    Commented Apr 7, 2012 at 16:48
  • @PaddyLandau: You are right. I found the ".eclipse" folder in my Home. But I couldn't find the "eclipse.ini" there, only a "eclipse.ini.ignored"??? Guess I'm going to install new fresh Eclipse, not via USC anymore? It gave me so much problem >_<
    – Anh Tuan
    Commented Apr 7, 2012 at 16:57
  • @AnhTuan Next time, if you get familiar to the terminal, try to run locate eclipse.ini
    – Lekensteyn
    Commented Apr 7, 2012 at 20:41
  • 1
    You may want to have a look at stackoverflow.com/q/8419099 This seems to answer your question.
    – qbi
    Commented Apr 7, 2012 at 22:07

1 Answer 1

5

How I installed subclipse
Changed /home/username/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/eclipse.ini.ignored
to /home/username/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/eclipse.ini just in case.

Installed subversion and the java wrapper
sudo apt-get install subversion libsvn-java
Check the version svn --version On 12.04 it's 1.6
I went to "Help->Install new software"
enter image description here
Added the matching site for svn integration. Make it match the version of libsvn.
enter image description here
Installed the full load of packages
enter image description here
Restarted eclipse from the command line to check for errors
I don't get any

I pulled an SVN repo to verify it working...ffmpeg svn is still up btw

1
  • Thank you very much! This line solves my problem "subclipse.tigris.org/update_1.6.x". I've tried to install Subclipse 1.8 and of course it wasn't compatible with my svn, but it threw a error dialog about JavaHL and that confused me. But when I followed your guide and installed Subclipse 1.6, everything was ok ^_^
    – Anh Tuan
    Commented Apr 8, 2012 at 4:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .