I have Ubuntu 18.04 and openvpn 2.4.4. When I try to connect with the vpn I can't use the internet anymore, only the resources behind the vpn. I can't even ping (all packets lost). Smh this only happened to me and not other people using the same script. However, this applies to 3 different devices of mine.

The following is the config content

dev tun
proto <tcp>
<ca> </ca>
<cert> </cert>
<key> </key>
remote-cert-eku "TLS Web Server Authentication"
remote x.x.x.x z
redirect-gateway def1
verb 3
mute 20
keepalive 10 60
cipher AES-256-CBC
auth SHA512
reneg-sec 3660
;remember_connection 0
;auto_reconnect 1

I have no idea anymore what is wrong here.

I did try the following solution approach: OpenVPN connecting but no internet access on Ubuntu 16.04 / 18.04

(first response)

But it does not work. When I check the box "use connection only for resources on its network" I can access the internet but I can not access the resources on my vpn network. If I dont check that box, I cant access the internet but I can access my vpn network resources.

  • Did it ever work? Confusing phrasing "can't use the internet anymore" – Organic Marble Dec 20 '19 at 13:25
  • No it never did. If I check the box: internet can be used, network behind the vpn cant be used. If I dont check the box: internet cant be used, network behind the vpn can be used. – Mnemosyne Dec 20 '19 at 13:28
  • Sounds backwards. I think you need a push command, will look at my config when i turn on a real pc. – Organic Marble Dec 20 '19 at 13:30
  • "cant use the internet anymore" means: once I run the vpn configuration file, internet can not be used. Before I ran the VPN, the internet could be normally accessed. When I run the vpn, I can access the network behind it. I just cant access the internet simultaneously. – Mnemosyne Dec 20 '19 at 13:30
  • What exactly do you mean by sounds backwards? This is literally what happens. Technically it shouldn't go like this though, that's true. – Mnemosyne Dec 20 '19 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.