0

i have Realtek audio chip ALC1220 in my MSI gp63 with GTX 1060. The speaker doesn't produce any sound; but, if I plug my earphones in, the earphones work fine.

I have tried to purge and reinstall alsamixer and have played with the audio in alsamixer to no avail.

I have tried installing Pulse Audio Volume Control, but nothing changes alsamixer shows I am using HDA intel PCH.

0

alsamixer and pulseaudio actually conflict with each other. But you cannot delete any of them since they are all required by Ubuntu

PulseAudio “official” website suggested that PulseAudio usually overwrites the ALSA settings.

PulseAudio has problems in recognizing the audio device, the user has to manually configure it by editing the /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf file.

1: Open terminal and type

sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

2: Change

[Element Desktop Speaker]
switch = off
volume = off

to

[Element Desktop Speaker]
switch = on
volume = on

This solution works because every time pulseaudio runs it uses this file to generate settings for analog-output-speaker profile which overwrites the settings set in alsamixer.

2
  • it did nothing ....except now when i press vol change combo key it shows the volume of headphone being changed....and then i put my real headphone in and plug it out then vol change key shows change happening to Digital output (s/pdif)....also the sound settings shows that there is only digital output (s/pdif) ....while before there was speaker in there tooo – drakal Dec 22 '19 at 16:58
  • edit:-i forgot to add this recent discovery before i applied your changes ....when i increase the volume of the headphone from the alsamixer the sound from speaker started to play . – drakal Dec 22 '19 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.